Fehler "Delta Lake-Aufnahmeauftrag konnte keine Version abrufen"

Notiz

Am 1. September 2023 haben wir Dynamics 365 Marketing und Dynamics 365 Customer Insights zusammengeführt und umbenannt. Dynamics 365 Marketing heißt jetzt Dynamics 365 Customer Insights - Journeys. Dynamics 365 Customer Insights heißt jetzt Dynamics 365 Customer Insights - Data. Weitere Informationen finden Sie in den Dynamics 365 Customer Insights – FAQs.

Dieser Artikel hilft Ihnen bei der Behebung des Fehlers "Delta Lake-Aufnahmeauftrag konnte keine Version abrufen", die auftreten kann, wenn Sie eine Verbindung mit Daten herstellen, die im Delta-Format in Microsoft Dynamics 365 Customer Insights - Data gespeichert sind.

Symptome

Eine Delta-Datenquelle in Dynamics 365 Customer Insights – Daten versuchen, eine Verbindung mit einer Tabelle herzustellen, die ein Feature verwendet, das eine Databricks minReaderVersion von 3 oder höher erfordert. In diesem Fall wird die folgende Fehlermeldung auf der Seite "Datenquellen " angezeigt:

Der Delta Lake-Aufnahmeauftrag konnte die Version <DataSourceId> nicht abrufen.

Wenn Sie die Spalten in der Tabelle anzeigen, wird der Fehler "Fehler beim Speichern des Datenquellenschemas" angezeigt.

Ursache

Dynamics 365 Customer Insights – Daten unterstützen Databricks-Features mit einer minReaderVersion oder einer früheren 2 Version. Databricks-Features, die databricks-Readerversion 3 oder höher erfordern, werden nicht unterstützt.

Lösung

Um dieses Problem zu beheben, entfernen Sie das Feature aus Ihrer Databricks-Installation, und setzen Sie die minReaderVersion Funktion auf 2. Weitere Informationen finden Sie unter "Unterstützte Databricks-Features und -Versionen".