Configuration Manager Clients erhalten keine Softwareupdates
In diesem Artikel wird ein Problem behoben, bei dem Configuration Manager Clients keine Updates vom Softwareupdatepunkt abrufen können.
Ursprüngliche Produktversion: Configuration Manager (Current Branch – Version 1702)
Ursprüngliche KB-Nummer: 4041012
Problembeschreibung
Nach der Installation Configuration Manager Current Branch Version 1702 können die folgenden Symptome auftreten:
- Neu installierte Clients können keine Updates vom Softwareupdatepunkt abrufen. Dies kann auch auftreten, wenn der Softwareupdatepunkt nach der Installation von Version 1702 auf einen anderen Server verschoben wird. Wenn die ausführliche Clientprotokollierung aktiviert ist, enthält die LocationServices.log-Datei einen leeren Wert für den
WSUSLocationReply
Eintrag. - Einige Computer werden in der Konsole als Unbekannter Zustand angezeigt.
Ursache
Ab Configuration Manager Current Branch Version 1702 verwenden Clients Begrenzungsgruppen, um einen neuen Softwareupdatepunkt zu finden und einen Fallback und einen neuen Softwareupdatepunkt zu finden, wenn der aktuelle Nicht mehr zugänglich ist. Wenn Sie einen neuen Standort installieren, an dem Version 1702 oder höher ausgeführt wird, müssen Sie Softwareupdatepunkte einer Begrenzungsgruppe zuweisen, bevor Clients sie finden und verwenden können.
Lösung
Fügen Sie den Server, auf dem der Softwareupdatepunkt ausgeführt wird, der Standard-Standortbegrenzungsgruppe für die Clients hinzu. Sie können einzelne Softwareupdatepunkte zu verschiedenen Begrenzungsgruppen hinzufügen, um zu steuern, welche Server ein Client finden kann. Weitere Informationen finden Sie unter Softwareupdatepunkte.
Führen Sie die folgenden Schritte aus, um den Softwareupdatepunkt der Begrenzungsgruppe hinzuzufügen:
- Erstellen Sie eine Begrenzungsgruppe, wenn keine vorhanden ist, und fügen Sie der Begrenzungsgruppe alle Clientcomputer mit dem Softwareupdatepunkt als Standortserver hinzu.
- Führen Sie den Auswertungszyklus zum Abrufen von Computerrichtlinien & auf dem Configuration Manager aus.
- Überprüfen Sie die LocationServices.log auf einem Clientcomputer, um sicherzustellen, dass der Client eine Verbindung mit dem WSUS-Server (Windows Server Update Services) herstellen kann.
Hinweis
Danach können temporäre Timeouts auftreten, wenn eine große Anzahl von Clients versucht, eine Verbindung mit dem WSUS-Server herzustellen. Dies kann auch zu einer hohen CPU-Auslastung auf dem WSUS-Server führen. Wenn die Clients eine Verbindung herstellen, sollte die CPU-Auslastung wieder normal werden. Wenn die hohe CPU-Auslastung weiterhin besteht, nachdem alle Clients verbunden sind, finden Sie weitere Informationen unter Problembehandlung bei hoher CPU-Auslastung auf einem WSUS-Server.