"AADSTS65005" error when you try to sign in to Microsoft Cloud services
Symptoms
When you use a company app to sign in to or authenticate to one of the Microsoft Cloud Services, such as Microsoft 365, Microsoft Intune, Microsoft Dynamics, Microsoft Power BI, or Microsoft Azure, or Microsoft Entra ID Federated Gallery Apps, you receive the following error message:
AADSTS65005: The client application has requested access to resource. This request has failed because the client has not specified this resource in its requiredResourceAccess list.
Cause
This issue occurs because the company's app may not be registered with Microsoft Entra ID, or it may not have the correct permissions applied.
Resolution
To fix this issue, use one of the following resources, depending on the services that you are trying to access:
- Microsoft 365: Manually register your app with Microsoft Entra ID so that it can access Microsoft 365 APIs
- Dynamics CRM: Register application for Dynamics CRM
- Problems signing in to a gallery application configured for federated single sign-on
More Information
For more information about how to register your app with Microsoft Entra ID, see the following Microsoft website: