Erreur AADSTS50003 : Aucune clé de signature configurée

Cet article décrit un problème dans lequel vous recevez le message d’erreur « Erreur AADSTS50003 - Aucune clé de signature configurée ». Lorsque vous essayez de vous connecter à une application configurée pour l’authentification unique (SSO) SAML qui a été intégrée à l’ID Microsoft Entra.

Symptômes

Vous recevez une erreur AADSTS50003 lors de la tentative de connexion à une application qui a été configurée pour utiliser l’ID Microsoft Entra pour la gestion des identités à l’aide de l’authentification unique basée sur SAML.

Cause

L’objet d’application est endommagé et l’ID Microsoft Entra ne reconnaît pas le certificat configuré pour l’application.

Résolution

Pour supprimer et créer un nouveau certificat, effectuez les étapes suivantes :

  1. Sur l’écran de configuration de l’authentification unique basée sur SAML, sélectionnez Créer un certificat sous Certificat de signature SAML.
  2. Sélectionnez une date d’expiration, puis cliquez sur Enregistrer.
  3. Cochez Make new certificate active (Activer le nouveau certificat) pour remplacer le certificat actif. Ensuite, cliquez sur Enregistrer en haut du volet, puis acceptez d’activer le certificat de substitution.
  4. Dans la section Certificat de signature SAML, cliquez sur Supprimer pour supprimer le certificat Inutilisé.

Informations supplémentaires

Pour obtenir la liste complète des codes d’erreur d’authentification et d’autorisation Active Directory, consultez les codes d’erreur d’authentification et d’autorisation Microsoft Entra

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