L’adresse IP du client ne peut pas accéder au serveur d’API

Cet article explique comment résoudre les problèmes qui se produisent lorsque vous ne pouvez pas vous connecter à un cluster Azure Kubernetes Service (AKS), car votre adresse IP cliente ne peut pas accéder au serveur d’API AKS.

Prerequisites

Symptômes

Lorsque vous essayez d’accéder à des ressources Kubernetes telles que des mamespaces et des charges de travail à partir de l’Portail Azure, vous pouvez rencontrer les erreurs suivantes :

Erreur réseau

Impossible d’atteindre le serveur d’API « https://< API-server-FQDN> » ou le serveur d’API est trop occupé pour répondre. Vérifiez vos paramètres réseau et actualisez pour réessayer.

Capture d’écran des mamespaces dans la ressource AKS.

Cause

Les plages d’adresses IP autorisées par le serveur d’API ont peut-être été activées sur le serveur d’API du cluster, mais l’adresse IP du client n’a pas été incluse dans les plages d’adresses IP. Pour vérifier si cette fonctionnalité a été activée, vérifiez si la commande az aks show suivante dans Azure CLI génère une liste de plages d’adresses IP :

az aks show --resource-group <cluster-resource-group> \
    --name <cluster-name> \
    --query apiServerAccessProfile.authorizedIpRanges

Solution

Examinez les plages autorisées par le serveur d’API du cluster et ajoutez l’adresse IP de votre client dans cette plage.

Note

  1. Accédez-vous au serveur d’API à partir d’un réseau d’entreprise où le trafic est acheminé via un serveur proxy ou un pare-feu ? Demandez ensuite à votre administrateur réseau avant d’ajouter votre adresse IP cliente à la liste des plages autorisées pour le serveur d’API.

  2. Demandez également à votre administrateur de cluster avant d’ajouter votre adresse IP cliente, car il peut y avoir des problèmes de sécurité liés à l’ajout d’une adresse IP temporaire à la liste des plages autorisées.

  1. Accédez au cluster à partir du Portail Azure.

  2. Dans le menu de gauche, recherchez Paramètres , puis sélectionnez Mise en réseau.

  3. Dans la page Mise en réseau, sélectionnez l’onglet Vue d’ensemble.

  4. Sélectionnez Gérer sous Paramètres de ressource.

  5. Dans le volet Plages d’adresses IP autorisées , ajoutez votre adresse IP cliente, comme illustré dans la capture d’écran suivante :

    Capture d’écran du volet Des plages d’adresses IP autorisées.

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