Résoudre les problèmes liés au code d’erreur « PublicIPCountLimitReached »
Cet article explique comment identifier et résoudre l’erreur « PublicIPCountLimitReached ». Cette erreur se produit lorsque vous essayez de créer, mettre à jour ou mettre à niveau un cluster Azure Kubernetes Service (AKS). Cette erreur peut également être due à toute autre action qui déclenche la création d’une adresse IP publique, telle que le déploiement d’un équilibreur de charge public de type Kubernetes Service.
Symptômes
Une création, une mise à jour, une mise à niveau ou une autre opération de cluster AKS qui déclenche la création d’une adresse IP publique, comme le déploiement d’un service Kubernetes avec un équilibreur de charge public, échoue et retourne un message d’erreur « PublicIPCountLimitReached ».
Cause
Cette erreur se produit si vous avez atteint le nombre maximal d’adresses IP publiques autorisées pour votre abonnement. La limite varie en fonction de votre type d’abonnement. Pour plus d’informations sur les limites d’adresses IP publiques, consultez ce guide détaillé.
Solution
Pour augmenter la limite ou le quota d’adresses IP publiques pour votre abonnement, procédez comme suit :
Accédez au Portail Azure, puis sélectionnez les abonnements pour lesquels vous effectuez l’opération.
Dans la section Paramètres , sélectionnez Utilisation + quotas. Définissez le fournisseur sur Mise en réseau et filtrez éventuellement par région de votre cluster AKS.
Recherchez l’enregistrement d’adresses IP publiques. Sur la même ligne, sélectionnez le bouton Créer une demande de support.
Dans la page Nouvelle demande de support, spécifiez la nouvelle limite dont vous avez besoin, puis suivez les instructions pour créer la demande de support.
Une fois la modification du quota appliquée, réessayez l’opération qui a initialement déclenché l’erreur « PublicIPCountLimitReached ».
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