Erreur « Échec de la tâche d’ingestion Delta Lake »

Note

Le 1er septembre 2023, nous avons fusionné et renommé Dynamics 365 Marketing et Dynamics 365 Customer Insights. Dynamics 365 Marketing devient Dynamics 365 Customer Insights - Journeys. Dynamics 365 Customer Insights est désormais Dynamics 365 Customer Insights - Data. Pour plus d’informations, consultez le FAQ sur Dynamics 365 Customer Insights.

Cet article vous aide à résoudre l’erreur « Échec de la tâche d’ingestion Delta Lake » qui peut se produire lorsque vous vous connectez aux données stockées au format Delta dans Microsoft Dynamics 365 Insights client - Données.

Symptômes

Source de données Delta dans Dynamics 365 Insights client : les données tentent de se connecter à une table qui utilise une fonctionnalité qui nécessite un Databricks minReaderVersion ou 3 une version ultérieure. Dans ce cas, le message d’erreur suivant s’affiche sur la page Sources de données :

Le travail d’ingestion Delta Lake n’a pas pu obtenir la version <DataSourceId>.

Lorsque vous affichez les colonnes de la table, l’erreur « Échec de l’enregistrement du schéma de source de données » s’affiche.

Cause

Dynamics 365 Insights client : les données prennent en charge les fonctionnalités Databricks avec un ou 2 plusieurs minReaderVersion versions antérieures. Les fonctionnalités Databricks qui nécessitent la version du lecteur Databricks ou une version 3 ultérieure ne sont pas prises en charge.

Résolution

Pour résoudre ce problème, supprimez la fonctionnalité de votre installation De Databricks et revenez à minReaderVersion 2. Pour plus d’informations, consultez Fonctionnalités et versions de Databricks prises en charge.