Impossible de supprimer une solution managée composée d’une entité prenant en charge le contrat SLA

Cet article fournit une résolution pour le problème dans lequel vous ne pouvez pas supprimer une solution managée composée d’une entité de contrat de niveau de service (SLA) dans Dynamics 365 Customer Service.

Symptômes

Vous ne pouvez pas supprimer une solution managée qui contient une entité sur laquelle un contrat SLA est activé. Cette entité a été créée dans le cadre d’une solution précédemment importée.

Cause

Une fois activé sur une entité, un contrat SLA ne peut pas être désactivé.

Utilisez cet exemple pour comprendre le problème :

  1. Create une nouvelle solution dans Org1 et nommez-la Solution de champ.
  2. Create une nouvelle entité dans la solution Field et nommez-la Travail de champ.
  3. Exporter la solution Field en tant que solution managée.
  4. Importez la solution Field dans une nouvelle organisation nommée Org2.

À suivre :

  1. Create une autre solution dans Org1 et nommez-la solution Delta Field.
  2. Associez le travail Field de l’entité à la solution Delta Field. Activez le contrat SLA sur l’entité.
  3. Exportez la solution Delta Field en tant que solution managée.
  4. Importez la solution Delta Field dans Org2.

À présent, si vous essayez de supprimer la solution Delta Field d’Org2, vous ne pouvez pas la supprimer, car une entité de travail Field est associée à laquelle le contrat SLA est activé.

Résolution

Pour supprimer une solution managée avec une entité prenant en charge le contrat SLA, vous devez d’abord supprimer la solution managée précédemment importée qui a créé l’entrée d’entité. Cette action garantit que l’entrée d’entité est supprimée. Ensuite, vous pouvez recréer l’entité ou réimporter la solution managée.

Pour supprimer la solution Delta Field dans Org2, supprimez d’abord la solution Field .

La solution de champ peut être supprimée, car le contrat SLA n’est pas activé pour l’entité qui lui est associée ( Travail sur le terrain). La solution de suppression de champ garantit que la configuration du contrat SLA et l’entité sont supprimées.

Remarque

Cette solution de contournement ne fonctionne pas pour les entités prêtes à l’emploi, car vous ne pouvez pas supprimer des entités prêtes à l’emploi ou des solutions managées qui ont des entités prêtes à l’emploi qui leur sont associées.