Les connexions de canaux nommés provoquent l’échec de SQL Server

Cet article vous aide à résoudre un problème d’authentification cohérente qui provoque un échec des connexions de canaux nommés à SQL Server.

Symptômes

Le fournisseur SQL OLE DB affiche le message d’erreur « SQL Server n’existe pas ou l’accès refusé ».

D’autres fournisseurs affichent les deux messages suivants dans un ordre aléatoire, que vous utilisiez la sécurité intégrée ou une connexion Microsoft SQL Server :

Une erreur liée au réseau ou spécifique à l’instance s’est produite lors de l’établissement d’une connexion à SQL Server. Le serveur est introuvable ou n’est pas accessible. Vérifiez que le nom de l’instance est correct et que SQL Server est configuré de manière à autoriser les connexions à distance.

Impossible d’ouvrir une connexion à SQL Server.

D’autres fournisseurs peuvent également afficher « Délai d’expiration de la connexion expiré » dans le message d’erreur.

Cause

Les connexions de canaux nommés échouent, car l’utilisateur n’est pas autorisé à se connecter à Windows.

Résolution

Ajoutez l’utilisateur au groupe Utilisateurs sur le serveur qui exécute SQL Server. Si SQL Server est mis en miroir ou en cluster, répétez cette opération sur tous les ordinateurs du groupe.

Informations supplémentaires

Problèmes d’authentification cohérente dans SQL Server