Impossibile aprire OWA, ECP o EMS dopo la rimozione di un certificato autofirma dal sito Web back-end di Exchange

Numero KB originale: 2779694

Sintomi

Si consideri lo scenario seguente quando si usa Microsoft Exchange Server 2013 o Exchange Server 2016:

  • Rimuovere il certificato di Microsoft Exchange Self-Signed dal sito Web back-end di Exchange usando MMC certificati, Remove-Exchangecertificate, Gestione IIS o un altro metodo.
  • Per cancellare la cache IIS, riavviare o IISReset.

In questo scenario, diversi protocolli client come Exchange Pannello di controllo (ECP), Outlook Web App (OWA), Exchange ActiveSync ed Exchange Management Shell (EMS) non possono connettersi. Possono verificarsi i problemi seguenti:

  • OWA ed ECP visualizzano una pagina vuota.

  • Exchange ActiveSync gli utenti non possono ricevere messaggi di posta elettronica.

  • EMS non è in grado di connettersi e visualizza l'errore seguente:

    New-PSSession : [xy.local.contoso.com] Processing data from remote server xy.local.contoso.com failed with the
    following error message: The WinRM Shell client cannot process the request. The shell handle passed to the WSMan Shell
    function is not valid. The shell handle is valid only when WSManCreateShell function completes successfully. Change
    the request including a valid shell handle and try again. For more information, see the about_Remote_Troubleshooting
    Help topic.
    At line:1 char:1
    + New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
       gTransportException
        + FullyQualifiedErrorId : -2144108212,PSSessionOpenFailed
    Failed to connect to an Exchange server in the current site.
    Enter the server FQDN where you want to connect.:
    

Causa

Durante il processo di installazione, un certificato autofirma denominato Microsoft Exchange è associato al sito Web back-end di Exchange sulla porta 444. Il certificato è destinato alla comunicazione tra il sito Web predefinito e i siti Web back-end di Exchange. Quando il certificato viene rimosso, il sito Web predefinito non può eseguire il proxy delle connessioni al sito Web back-end di Exchange.

Risoluzione

Per risolvere questo problema, aggiungere di nuovo il certificato al sito Web back-end di Exchange creando un nuovo certificato autofirma e quindi associarlo al sito Web back-end di Exchange.

Nota

Questi passaggi devono essere eseguiti nel ruolo del server Cassette postali di Exchange.

  1. Avviare Management Shell nel server Cassette postali.
  2. Digitare New-ExchangeCertificate.

    Nota

    Se viene richiesto di sovrascrivere il certificato predefinito, selezionare No.

  3. Avviare Gestione IIS nel server cassette postali.
  4. Espandere Sito, evidenziare Back-End di Exchange e selezionare Associazioni nel riquadro Azioni nella colonna a destra.
  5. Selezionare Tipohttps sulla porta 444.
  6. Selezionare Modifica e selezionare il certificato di Microsoft Exchange.
  7. Da un prompt dei comandi dell'amministratore eseguire IISReset.