Errore durante l'esecuzione di una ricerca in più cassette postali in Exchange Server 2010: l'utente non dispone di una cassetta postale di Exchange

Numero KB originale: 2702446

Sintomi

Considerare lo scenario descritto di seguito:

  • Avviare Exchange Pannello di controllo (ECP) in Microsoft Exchange Server 2010 Enterprise o in Exchange Server 2010 Standard.
  • Si esegue una ricerca in più cassette postali.
  • La ricerca in più cassette postali usa una cassetta postale di sistema, una cassetta postale di ricerca di individuazione o una cassetta postale federata come destinazione per la ricerca.

In questo scenario, è possibile che venga visualizzato il messaggio di errore seguente:

L'utente non dispone di una cassetta postale di Exchange

Inoltre, nel log dell'applicazione viene registrato l'evento seguente:

Log Name: Application
Source: MSExchange Configuration Cmdlet - Remote Management
Event ID: 5
Task Category: General
Level: Error
Keywords: Classic
Description:
(PID 6268, Thread 53) Task New-MailboxSearch throwing terminating exception at stage Microsoft.Exchange.Data.Storage.UserHasNoMailboxException: The user does not have an Exchange mailbox.
at Microsoft.Exchange.Data.Storage.ExchangePrincipal.InternalFromADUser(ADUser user, ADObjectId mdb, DatabaseLocationInfo databaseLocationInfo, Boolean ignoreSiteBoundary)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataStore.OpenMailboxSession(ADUser adUser)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataStore..ctor(ADUser adUser)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.OpenMailboxStore()
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.Exists[T](String name)
at Microsoft.Exchange.Management.Tasks.NewMailboxSearch.PreSaveValidate(SearchObject savedObject)
at Microsoft.Exchange.Management.Tasks.NewMailboxSearch.InternalEndProcessing(). Exception: {4c1ab22a-bd1d-41e9-b178-5e75ffd14563}

Causa

Questo problema può verificarsi se una o più delle cassette postali seguenti si trovano in uno stato incoerente perché non è impostato alcun valore per l'attributo HomeMDB :

  • Una o più cassette postali di sistema
  • Cassetta postale federata
  • Cassetta postale di Ricerca individuazione

Risoluzione

Per risolvere il problema, seguire la procedura seguente:

  1. Avviare ECP.

  2. Verificare che una o più cassette postali siano in uno stato incoerente. A tale scopo, digitare il cmdlet seguente e quindi premere INVIO:

    Get-Mailbox -Arbitration |fl name, alias
    

    Nota

    È possibile che venga visualizzato un messaggio di errore simile al seguente. Questo messaggio di errore conferma che una o più cassette postali di sistema o la cassetta postale federata si trovano in uno stato incoerente:

    AVVISO: l'oggetto SystemMailbox{1f05a927-9daf-4003-9bf7-036822f96290} è stato danneggiato ed è
    in uno stato incoerente. Si sono verificati gli errori di convalida seguenti:
    AVVISO: il database è obbligatorio in UserMailbox.
    AVVISO: il database è obbligatorio in UserMailbox.

  3. Verificare che il valore per l'attributo HomeMDB non sia presente per una cassetta postale. A tale scopo, digitare il cmdlet seguente in ECP e quindi premere INVIO:

        Get-Mailbox |fl name, alias
    

    Nota

    Il messaggio di errore seguente indica che il valore dell'attributo HomeMDB è mancante:
    Il database è obbligatorio in UserMailbox

  4. Copiare il valore dell'attributo HomeMDB per una cassetta postale nello stesso database della cassetta postale di sistema, della cassetta postale federata o della cassetta postale di Ricerca individuazione. A tal fine, attenersi alla seguente procedura:

    1. Fare clic su Start, digitare Adsi Edit nella casella Cerca programmi e file e quindi premere INVIO.

    2. Scegliere Connetti a dal menu Azione.

    3. Fare clic su Seleziona o digitare un dominio o un server, selezionare il server desiderato e quindi fare clic su OK.

    4. Espandere Contesto di denominazione predefinito e quindi fare clic sull'elemento seguente:

      DC=domain,DC=com

    5. Fare doppio clic su CN=Users.

    6. Fare clic con il pulsante destro del mouse su una cassetta postale utente e quindi scegliere Proprietà.

    7. In Attributo fare clic su homeMDB>Edit (Modifica database home).

    8. Copiare il valore per l'attributo HomeMDB e quindi fare clic su OK due volte.

  5. Impostare il valore dell'attributo HomeMDB nella cassetta postale di sistema, nella cassetta postale federata o nell'account della cassetta postale di Ricerca individuazione. A tal fine, attenersi alla seguente procedura:

    1. In Modifica ADSI fare clic con il pulsante destro del mouse sull'account per la cassetta postale di sistema, la cassetta postale federata o la cassetta postale ricerca individuazione, quindi fare clic su Proprietà.
    2. In Attributo fare clic su homeMDB>Edit (Modifica database home).
    3. Digitare o incollare il valore dell'attributo HomeMDB copiato nel passaggio 4.
    4. Fare due volte clic su OK.
  6. Scegliere Esci dal menu File.

  7. Replicare la foresta. A tale scopo, digitare il cmdlet seguente al prompt dei comandi con privilegi elevati e quindi premere INVIO:

    repadmin /syncall /e
    

Ulteriori informazioni

Per altre informazioni sull'attributo HomeMDB , vedere Proprietà HomeMDB.

Per altre informazioni su un problema che può verificarsi quando il valore dell'attributo HomeMDB è mancante nella cassetta postale operatore di sistema, vedere Attributo homeMDB del supervisore di sistema mancante.