Errore "AADSTS65005" quando si tenta di accedere ai servizi cloud Microsoft
Sintomi
Quando si usa un'app aziendale per accedere o eseguire l'autenticazione a uno dei Servizi cloud Microsoft, ad esempio Microsoft 365, Microsoft Intune, Microsoft Dynamics, Microsoft Power BI o Microsoft Azure o Microsoft Entra ID Federated Gallery Apps, viene visualizzato il messaggio di errore seguente:
AADSTS65005: l'applicazione client ha richiesto l'accesso alla risorsa. Questa richiesta non è riuscita perché il client non ha specificato questa risorsa nell'elenco requiredResourceAccess.
Causa
Questo problema si verifica perché l'app aziendale potrebbe non essere registrata con Microsoft Entra ID o potrebbe non avere le autorizzazioni corrette applicate.
Risoluzione
Per risolvere questo problema, usare una delle risorse seguenti, a seconda dei servizi a cui si sta tentando di accedere:
- Microsoft 365: registrare manualmente l'app con Microsoft Entra ID in modo che possa accedere alle API di Microsoft 365
- Dynamics CRM: Registrare l'applicazione per Dynamics CRM
- Problemi di accesso a un'applicazione della raccolta configurata per l'accesso Single Sign-On federato
Ulteriori informazioni
Per altre informazioni su come registrare l'app con Microsoft Entra ID, vedere il sito Web Microsoft seguente: