Office 2013 non può archiviare i file quando la rete LAN non ha accesso a Internet o tramite alcune VPN

Questo articolo è stato scritto da Warren Rath, Support Escalation Engineer.

Nei casi in cui la VPN causa questo problema, è stato rilevato un problema nel codice di Windows (113100710844135), la correzione è out Client VPN di terze parti arresta la connettività Internet in Windows 7 SP1 o Windows Server 2008 R2 SP1. È stato verificato che Palo Alto Networks Global Protect Client e Juniper VPN funzionino con questa correzione.

I clienti usano soluzioni VPN di terze parti in Windows 7. Se i clienti eseguono la migrazione a Office 2013 da una versione precedente di Office, potrebbero riscontrare una perdita di funzionalità in Office quando sono connessi tramite VPN. Office 2013 ha assunto una dipendenza da NLA (Network Location Awareness) e alcune soluzioni VPN non funzionano correttamente con NLA. In particolare, se il software VPN non definisce un gateway predefinito. In questo caso, NLA segnalerà sempre che il client non è connesso a Internet. Ciò influisce su Office 2013 perché dipende dalla connettività Internet per alcune funzioni. Ad esempio, nel computer non è presente alcun file della Guida e tutta la Guida è disponibile su Internet. Se un cliente preme F1 in un'applicazione di Office 2013, riceverà sempre un errore che indica di non essere connesso a Internet durante la connessione tramite VPN.

Sintomi

Gli utenti senza accesso a Internet completo potrebbero non essere in grado di archiviare i file dal client di Office 2013, anche se esiste una buona connessione tra il client di Office e il server SharePoint.

Causa

È stata apportata una modifica alla progettazione tra Office 2010 e 2013, in cui il 2013 richiede ora una connessione Internet per alcune attività. Alcuni clienti si sono già lamentati di questo problema e il gruppo di prodotti è stato informato delle limitazioni di progettazione. (Ma non è attualmente disponibile alcun hotfix, potrebbe non essere possibile che questo aspetto sia una modifica significativa)

La radice del problema sembra essere che Office 2013 ha una dipendenza da NLA (Network Location Awareness). NlA usa probe per determinare se la connessione di rete ha "Accesso Internet". Il modo in cui lo fa è in due modi.

  1. Esegue un probe DNS per dns.msftncsi.com. Si aspetta una risposta specifica. La risposta deve essere 131.107.255.255. In caso affermativo, si tratta del probe DNS corretto.
  2. Tenta di connettersi a https://www.msftncsi.com e tenta di recuperare il file ncsi.txt. All'interno del file, il testo deve essere "Microsoft NCSI".

Se vengono soddisfatte entrambe le condizioni precedenti, la connessione viene contrassegnata come con connettività Internet, se non è contrassegnata come priva di connettività Internet e alcune funzionalità di Office non funzionano.

Soluzione alternativa

È possibile configurare un server NCIS locale (indicatore di stato della connessione di rete) nella rete LAN che risponderà alla richiesta dei client di Office e consentirà il funzionamento della funzionalità office.

Vedere il post seguente per informazioni e indicazioni correlate: