Gli utenti che usano le regole outlook per iOS e Android e Accesso al dispositivo (ABQ) vengono messi in quarantena in modo imprevisto
Numero KB originale: 3193518
Sintomi
Exchange Online gli utenti che usano Outlook per iOS e Android e che usano anche le regole di Accesso al dispositivo (ABQ) rilevano di essere stati messi in quarantena in modo imprevisto. Questo problema si verifica nello scenario seguente:
- La proprietà del
DefaultAccessLevel
tenant configurata tramiteSet-ActiveSyncOrganizationSettings
è impostata su un valore di Quarantine o Block. - L'amministratore del tenant in precedenza consentiva Outlook per iOS e Android contrassegnando deviceID nella
ActiveSyncAllowedDeviceIDs
proprietà della cassetta postale. - I dispositivi non sono gestiti da Microsoft Intune.
Causa
Una modifica del protocollo back-end nella modalità di accesso ai dati delle cassette postali di Microsoft 365 tramite outlook per applicazioni iOS e Android modifica il DeviceID usato dall'app per connettersi a Exchange Online. Il comportamento previsto prevede che il nuovo DeviceID venga aggiunto automaticamente all'oggetto ActiveSyncAllowedDeviceID
per l'utente. In alcuni scenari, tuttavia, il dispositivo può essere messo in quarantena. In questi casi, seguire i passaggi descritti nella sezione Risoluzione. Questo problema non si verifica ripetutamente.
Risoluzione
Contattare il supporto tecnico e chiedere al rappresentante del servizio clienti di sbloccare il dispositivo.
In alternativa, usare uno dei metodi seguenti per sbloccare il dispositivo:
Usare l'interfaccia di amministrazione di Exchange per sbloccare singoli dispositivi. A tal fine, attenersi alla seguente procedura:
- Accedere a Interfaccia di amministrazione di Exchange. Per altre informazioni, vedere Interfaccia di amministrazione di Exchange in Exchange Online.
- Selezionare Dispositivi mobili e quindi in Dispositivi in quarantena selezionare il pulsante Consenti per ogni dispositivo app Outlook per iOS e Android che deve essere sbloccato.
Usare PowerShell remoto per sbloccare tutti i dispositivi. A tal fine, attenersi alla seguente procedura:
Connettersi a Exchange Online tramite una sessione remota di PowerShell. Per ulteriori informazioni, vedere Connessione a Exchange Online PowerShell.
Copiare e incollare il codice seguente nella sessione remota di PowerShell:
function FixUnblock { $Mbxs = Get-CASMailbox -ResultSize 10000 | ?{$_.ActiveSyncAllowedDeviceIDs -ne $null } foreach($Mbx in $Mbxs) { write-host $Mbx.Id $IdList = Get-MobileDevice -Mailbox $Mbx.Id | where {$_.DeviceModel -eq "Outlook for iOS and Android" -and $_.ClientType -eq "REST" -and $_.DeviceAccessState -ne "Allowed" -and $_.FirstSyncTime -ge "9/13/2016"} $CasDevice = Get-CasMailbox $Mbx.Id foreach( $Id in $IdList) { $CasDevice.ActiveSyncAllowedDeviceIDs += $Id.DeviceId } Set-CasMailbox $Mbx.Id -ActiveSyncAllowedDeviceIDs $CasDevice.ActiveSyncAllowedDeviceIDs } }
Nella sessione remota di PowerShell eseguire la funzione . A tale scopo, digitare FixUnblock e quindi premere INVIO.
Ulteriori informazioni
Gli utenti con account abilitati per l'autenticazione moderna devono seguire la procedura descritta in Configurazione account con autenticazione moderna in Exchange Online per configurare gli account Outlook per iOS e Android.
Ulteriore assistenza Visitare la community Microsoft.