Errore "403 Non consentito" in OneDrive o SharePoint

Sintomi

Quando si tenta di accedere a un file da un sito Web di OneDrive o SharePoint condiviso da un altro utente, viene visualizzato il messaggio di errore seguente:

Errore: 403 Non consentito

Causa

L'errore "403 Forbidden" potrebbe verificarsi a causa di una delle condizioni seguenti:

  • La cache del browser deve essere cancellata.

  • Le autorizzazioni per il file non sono replicate correttamente nel server.

  • Il sito di OneDrive è bloccato.

  • Un problema interessa i servizi SharePoint Online dell'organizzazione.

Risoluzione

Usare la modalità di privacy disponibile del Web browser quando si accede a Microsoft 365. Ad esempio, usare la modalità InPrivate in Microsoft Edge o la modalità in incognito in Google Chrome. Provare quindi ad accedere al file. Per informazioni su come esplorare una finestra InPrivate, vedere Microsoft Edge. Per informazioni su come esplorare una finestra in incognito, vedi Google Chrome.

Se è possibile accedere al file durante l'esplorazione in modalità privacy, deselezionare la cache del browser. Per informazioni su come cancellare la cache del browser, vedere Edge o Chrome.

Se il problema non viene risolto, contattare l'amministratore di SharePoint o OneDrive per l'organizzazione. Se non si sa chi sia, vedere Ricerca per categorie trovare l'amministratore di Microsoft 365?

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Azioni per gli amministratori

Se la cancellazione della cache non risolve il problema, provare i metodi seguenti.

Ricondividere il file

È possibile che le autorizzazioni per il file non siano replicate correttamente o completamente. Chiedere all'utente di attendere 30 minuti prima di provare di nuovo ad accedere al file. Se l'errore persiste dopo 30 minuti, provare i passaggi elencati in "Quando si accede a un sito di SharePoint" o "Quando si accede a un sito di OneDrive" in "Accesso negato", "È necessaria l'autorizzazione per accedere a questo sito" o "Utente non trovato nella directory" in SharePoint Online e OneDrive for Business.

Controllare se il sito di OneDrive è bloccato

È possibile che il sito di OneDrive dell'utente sia in uno stato "NoAccess" bloccato. In qualità di amministratore globale o di SharePoint in Microsoft 365, è possibile sbloccare il sito usando PowerShell o eseguendo una diagnostica di Microsoft 365. Per altre informazioni, vedere Messaggi di errore di sola lettura di SharePoint o OneDrive.

Controllare l'integrità del servizio

Come amministratore, passare alla pagina Integrità dei servizi (Integrità>Integrità dei servizi) nel Centro Amministrazione Microsoft 365. Verificare la presenza di avvisi o eventi imprevisti che potrebbero verificarsi. Se non si verificano avvisi o eventi imprevisti per SharePoint Online, è possibile selezionare Segnala un problema se è disponibile o aprire una nuova richiesta di servizio con il supporto tecnico di Microsoft 365.

Effettuare il provisioning del sito di OneDrive

L'errore 403 può verificarsi se l'utente tenta di accedere a un sito di OneDrive di cui non è stato effettuato il provisioning. Fare in modo che l'utente provi a passare al riquadro di OneDrive dal portale di Microsoft 365.

Se non funziona, effettuare il provisioning del sito usando il cmdlet Request-SPOPersonalSite .

Accedere ai dati di OneDrive di un altro utente

Se l'utente sta tentando di accedere ai dati di OneDrive di un altro utente, ad esempio un ex dipendente, è possibile concedere le autorizzazioni all'utente seguendo la procedura descritta in Passaggio 4 - Concedere a un altro dipendente l'accesso ai dati di OneDrive e Outlook.