Skype for Business riproduce un tono di composizione durante una chiamata a Teams

Sintomi

In una chiamata di Microsoft Teams, il client microsoft Skype for Business dispone dei controlli HID (Human Interface Device) abilitati in modalità Isole. Durante la chiamata, se si avvia Skype for Business o si preme il pulsante Hook su un hid che supporta la funzionalità Flash, il client trasmette un tono di chiamata per 30 secondi a tutti i partecipanti alla chiamata.

Causa

È disponibile una nuova funzionalità HID per gli utenti in modalità Isole in Teams per abilitare i controlli Mute/Unmute (vedere la sezione "Altre informazioni" per informazioni dettagliate). Questa funzionalità richiede che la versione del client Skype for Business sia 16.0.11020.10000 o successiva.

Se il client Skype for Business è precedente alla 16.0.11020.10000, questo problema si verifica quando viene premuto il pulsante hook.

Questo problema si verifica anche se Skype for Business viene avviato durante una chiamata a Teams. Questo vale per tutte le versioni di Skype for Business.

Soluzione alternativa

Nota: Usare uno dei metodi seguenti per risolvere il problema se si verifica quando viene premuto il pulsante Hook. Usare il metodo 1 o 2 per risolvere il problema se si verifica quando Skype for Business viene avviato durante una chiamata di Teams.

Metodo 1

Impostare il tono di composizione su Nessuno per Skype for Business.

Gli amministratori:

Usare il Registro di sistema di Windows per modificare l'impostazione del tono di composizione per tutti gli utenti. Cancellare i dati nella sottochiave del Registro di sistema seguente:

HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Communicator\LYNC_dialtone\.Current\Default

Singoli utenti:

Accedere alle impostazioni di Windows per modificare l'impostazione del tono di composizione, come indicato di seguito:

  1. Aprire l'app Impostazioni e selezionare System>Sound>Sound Pannello di controllo.
  2. Selezionare la scheda Suoni .
  3. Nella sezione Eventi programma scorrere verso il basso per individuare Skype for Business.
  4. Nel nodo Skype for Business selezionare Dial Tone.Under the Skype for Business node, select Dial Tone.
  5. Nella sezione Suoni scorrere fino alla parte superiore dell'elenco, selezionare Nessuno e quindi selezionare OK.

Screenshot che mostra l'impostazione del suono Dial Tone su Nessuno.

Metodo 2

Impostare su PlayAbbreviatedDialToneTrue nei criteri client. Se PlayAbbreviatedDialTone è impostato su True, viene riprodotto un tono di quadrante di tre secondi quando un portatile compatibile con Skype for Business viene tolto dal gancio. Per altre informazioni, vedere Set-CsClientPolicy. Per impostare il valore, eseguire il comando seguente:

Set-CsClientPolicy -Identity RedmondClientPolicy  -PlayAbbreviatedDialTone $True

Metodo 3

Abilitare le funzionalità di interoperabilità HID nel client Skype for Business. Per informazioni su come, vedere EnableTeamsHIDInterop per il coordinamento dell'utilizzo dei dispositivi HID in Microsoft Teams e Skype for Business 2016 in modalità Isole.

Ulteriori informazioni

Per migliorare l'esperienza utente, Microsoft ha implementato una nuova funzionalità HID per abilitare un controllo Mute/Unmute per gli utenti in modalità Isole in Teams.

Questa funzionalità si applica solo a Windows (32 bit).

A causa della disponibilità dei nuovi controlli HID Mute/Unmute , i controlli disponibili in precedenza, ad esempio Hook/OffHook , non sono più supportati. Tuttavia, i controlli volume e tono circolare continueranno a funzionare come prima.