L'aggiornamento dei dati non riesce e l'aggiornamento del flusso di dati viene ignorato
Nota
Il 1° settembre 2023 è stato unito e rinominato Dynamics 365 Marketing e Dynamics 365 Customer Insights. Dynamics 365 Marketing è ora chiamato Dynamics 365 Customer Insights - Journeys. Dynamics 365 Customer Insights è ora chiamato Dynamics 365 Customer Insights - Data. Per altre informazioni, vedere domande frequenti su Dynamics 365 Customer Insights.
Questo articolo fornisce una soluzione per un problema per cui l'origine dati Power Query non viene aggiornata correttamente in Microsoft Dynamics 365 Customer Insights - Data.
Sintomi
Lo stato di elaborazione dell'origine dati Power Query è Completato con errori e viene visualizzato il messaggio di errore seguente:
Aggiornamento attivato dal sistema riuscito; Tuttavia, l'aggiornamento del flusso di dati è stato ignorato perché le impostazioni di aggiornamento del sistema non sono applicabili per questa origine dati. Se si vuole che l'origine dati venga aggiornata periodicamente, configurare l'aggiornamento pianificato tramite le opzioni "Modifica impostazioni di aggiornamento".
Causa
Dynamics 365 Customer Insights - Data dispone di due opzioni di aggiornamento: aggiornamento del sistema e aggiornamento dell'origine dati. Power Query l'aggiornamento basato su viene impostato dal proprietario di ogni origine dati. L'aggiornamento del sistema viene impostato dall'amministratore e controlla il resto delle origini dati e dei processi downstream.
Il messaggio di errore indica che l'aggiornamento del sistema in Customer Insights non viene aggiornato Power Query'origine dati, ma copia solo lo stato precedente dell'origine dati.
Risoluzione
Per risolvere questo problema, configurare la pianificazione dell'aggiornamento per l'origine dati Power Query modificando le impostazioni dell'origine dati.