Si verifica un errore di autenticazione nel dashboard dell'agente dopo il provisioning di Omnichannel for Customer Service

Questo articolo fornisce una soluzione per il problema in cui il dashboard dell'agente visualizza un errore di autenticazione dopo il provisioning di Omnichannel per il servizio clienti.

Sintomi

Il messaggio di errore seguente viene visualizzato nel dashboard dell'agente dopo il provisioning di Omnichannel per il servizio clienti:

Si è verificato un problema durante l'autenticazione. Riprovare. Se questa operazione continua, chiedere all'amministratore di contattare supporto tecnico Microsoft con l'ID sessione client.

Causa

Il problema si verifica quando si rinomina l'URL dell'organizzazione ma non si aggiorna l'URL del canale dopo aver effettuato il provisioning di Omnichannel per il servizio clienti.

Risoluzione

Per risolvere il problema,

  1. Passare a Power Apps.

  2. Nel riquadro sinistro selezionare App e quindi nell'elenco delle applicazioni selezionare Omnichannel for Customer Service.On the left pane, select Apps, and then from the applications list, select Omnichannel for Customer Service.

  3. Selezionare il pulsante con i puntini di sospensione (...), scorrere verso il basso l'elenco e selezionare Gestione profili app.

  4. Selezionare un'app di amministrazione, ad esempio l'interfaccia di amministrazione del servizio clienti, quindi selezionare Provider di canali. Viene visualizzato l'elenco Provider di canali attivi .

  5. Seguire questa procedura:

    1. Assicurarsi che il record del provider di canali omnicanale sia elencato e che sia nello stato attivo. Se il record omnicanale non è attivo, selezionare il record e quindi selezionare Attiva sulla barra dei menu.

    2. Nella scheda Generale del record omnicanale verificare che il campo URL canale includa le informazioni dell'organizzazione come illustrato nell'esempio seguente:

      https://oc-cdn-ocprod.azureedge.net/convcontrol/ChatControl.htm?uci=true&clientName=zfp&cloudType=Public&env=prod&ocBaseUrl=https://org749544d7-crm.omnichannelengagementhub.com&ucilib=https:// <org>.crm.dynamics.com/webresources/Widget/msdyn_ciLibrary.js