Lo stato dell'istanza KPI del contratto di servizio viene visualizzato come Annullato

Questo articolo fornisce una soluzione per il problema in cui lo stato dell'istanza KPI dei contratti di servizio viene visualizzato come Annullato.

Sintomi

Quando si aggiorna il record di destinazione, in modo che la condizione Applicabile quando/da modifiche non sia più applicabile, lo stato dell'indicatore KPI del contratto di servizio passa da uno degli stati esistenti di In corso, Completato, Quasi non conformità o Scaduto allo stato Annullato . L'istanza KPI del contratto di servizio viene annullata nella seconda valutazione perché la condizione Applicabile quando non viene più soddisfatta. Si consideri lo scenario seguente in cui si crea un contratto di servizio con le condizioni seguenti e lo si imposta come contratto di servizio predefinito.

  • Applicabile quando/da modifiche: lo stato del case è uguale a attivo.
  • Condizione di esito positivo: lo stato del case è uguale a risolto.
  1. Creare un caso. Lo stato del caso è impostato su Attivo per impostazione predefinita, viene applicato il contratto di servizio e viene avviato il timer del contratto di servizio.
  2. Risolvere il caso. Lo stato del caso è impostato su Risolto e il contratto di servizio viene rivalutato per la condizione Applicabile quando/da modifiche . Lo stato dell'istanza KPI del contratto di servizio verrà impostato su Annullato.

Causa

Quando si definisce la condizione Applicabile quando/da modifiche e Success sullo stesso attributo, ad esempio lo stato del caso, uno dei criteri potrebbe non essere soddisfatto e lo stato dell'istanza KPI del contratto di servizio verrà Annullato.

Nota

Quando si definiscono le condizioni sullo stesso attributo, viene visualizzato un messaggio di raccomandazione che suggerisce di non usare lo stesso attributo.

Risoluzione

In questi scenari, è consigliabile non definire la condizione Applicabile quando/da modifiche e Esito positivo sullo stesso attributo.