L'impostazione dei messaggi di posta elettronica di protezione per il ripristino delle impostazioni predefinite non viene applicata dopo la reimpostazione di un dispositivo Android Enterprise

Questo articolo fornisce una soluzione per il problema che l'impostazione dei messaggi di posta elettronica di protezione del ripristino delle impostazioni predefinite non funziona come previsto per un dispositivo Android Enterprise Device Owner registrato.

Sintomi

Considerare lo scenario descritto di seguito:

  • Si dispone di un dispositivo Android Enterprise registrato in Microsoft Intune.

  • L'impostazione Dei messaggi di posta elettronica di protezione per la reimpostazione delle impostazioni predefinite è abilitata e viene fornito un indirizzo di posta elettronica, come illustrato nello screenshot seguente:

    Screenshot dell'impostazione dei messaggi di posta elettronica di protezione per la reimpostazione delle impostazioni predefinite e di un indirizzo di posta elettronica di esempio.

  • È possibile eseguire un ripristino delle impostazioni predefinite nel dispositivo tramite il menu Impostazioni (ad esempio, toccare Impostazioni>Reimpostazione> deidati della factory digestione> generale) oppure cancellare il dispositivo da Intune nell'interfaccia di amministrazione Microsoft Intune.

In questo scenario, è possibile attivare il dispositivo usando un account Google che non è incluso nell'impostazione dei messaggi di posta elettronica di protezione per la reimpostazione della fabbrica .

Causa

Questo comportamento è previsto. Quando si esegue un ripristino delle impostazioni predefinite nel dispositivo tramite il menu Impostazioni o si cancella il dispositivo da Intune nell'interfaccia di amministrazione Microsoft Intune, tutti i dati vengono rimossi. Sono inclusi i dati di Factory Reset Protection (FRP).

Soluzione

L'unico modo per eseguire un ripristino delle impostazioni predefinite nel dispositivo senza perdere i dati FRP è tramite la modalità di ripristino.

È consigliabile impostare il valore di reimpostazione delle impostazioni predefinite su Blocca per impedire agli utenti di usare l'opzione di reimpostazione delle impostazioni predefinite nelle impostazioni del dispositivo.

Screenshot delle opzioni di reimpostazione delle impostazioni predefinite.

Usare quindi uno dei metodi seguenti quando si reimposta il dispositivo alle impostazioni della factory:

  • Reimpostare il dispositivo tramite la modalità di ripristino.
  • Cancellare il dispositivo da Intune quando il dispositivo è in tuo possesso e dovrebbe essere reimpostato per un ulteriore utilizzo.