"Aggiorna tutto" non funziona dopo l'esportazione dei dati dell'app in un foglio di lavoro dinamico

Sintomi

Usare il comando Esporta in Excel per esportare i dati dell'app in un foglio di lavoro dinamico. Aprire quindi il file scaricato e aggiornare i dati selezionandoAggiorna tutti idati>. In questo caso, i dati scompaiono e la cartella di lavoro viene visualizzata vuota. È possibile che venga visualizzato il messaggio di errore seguente:

Questa query Web non ha restituito dati. Per modificare la query, fare clic su OK, fare clic sulla freccia sulla casella del nome nella barra della formula, scegliere il nome dell'intervallo di dati esterno per la query Web, fare clic con il pulsante destro del mouse sulla selezione e quindi scegliere Modifica query.

Screenshot che mostra che la query Web non ha restituito alcun errore di dati che si verifica dopo l'aggiornamento dei dati esportati dell'app.

Causa

Questo problema si verifica quando i dati a cui si accede sono protetti da password e il file di Excel non può inviare password a origini dati esterne.

Risoluzione

Per risolvere questo problema, è necessario modificare e salvare la query Web.

  1. Nel file di Excel selezionare Query dati>& Connections.

    Screenshot che mostra l'opzione Query e Connections nella scheda Dati.

  2. Il riquadro Query & Connections si apre a destra della finestra. Nella scheda Connections fare clic con il pulsante destro del mouse sulla query e quindi scegliere Proprietà.

    Screenshot che mostra le impostazioni delle proprietà di una query nel riquadro Query e Connections.

  3. Verrà visualizzata la finestra Proprietà connessione . Nella scheda Definizione selezionare Modifica query.

    Screenshot che mostra il pulsante Modifica query nel Finestra Proprietà Connessione.

  4. Se richiesto, immettere il nome utente e la password. Immettere lo stesso utente e la stessa password usati per accedere all'app.

  5. Nella finestra Modifica query Web selezionare Vai. Si verifica un messaggio di errore:

    Non è possibile completare questa azione

    Screenshot che mostra il pulsante Vai nella finestra Modifica query Web.

  6. Chiudere la finestra Modifica query Web .

  7. Questo dovrebbe risolvere il problema. Aggiornare nuovamente i dati nel foglio di lavoro selezionandoAggiorna tutti idati>.

    Screenshot che mostra come aggiornare i dati dell'app in Excel.

Se la procedura precedente non risolve il problema, seguire questa procedura aggiuntiva:

  1. Immettere il collegamento seguente nella barra degli indirizzi della finestra Modifica query Web per accedere alla pagina Impostazioni avanzate in Microsoft Dynamics 365 Customer Engagement. Ricordarsi di sostituire OrgURL con l'URL dell'organizzazione.

    https://OrgURL/main.aspx?settingsonly=true

  2. Disconnettersi usando il collegamento all'opzione del profilo in alto a destra e quindi accedere di nuovo usando l'identità corretta.

  3. Dopo aver eseguito l'accesso, chiudere la finestra Modifica query Web e quindi nel file di Excel selezionareAggiorna tutti idati>. I dati verranno aggiornati come previsto.

Vedere anche

Esportare dati in un foglio di lavoro dinamico di Excel