サーバーに新しい証明書をインストールした後、ハイブリッド環境でメールを受信できない

元の KB 番号: 2989382

現象

Exchange Server ハイブリッド環境に新しい Exchange 証明書をインストールすると、次のような現象が発生します。

  • トランスポート層セキュリティ (TLS) を使用する場合、インターネットまたは Microsoft 365 からメールを受信することはできません。

  • Telnet (例: telnet localhost 25) を使用して簡易メール転送プロトコル (SMTP) 通信を調べると、コマンドが欠落している STARTTLS ことがわかります。

  • イベント ビューアーでアプリケーション ログを調べると、次のようなイベント エントリが表示されます。

    ログ名: アプリケーション
    ソース: MSExchangeFrontEndTransport
    日付: MM/DD/YYYY 0:00:00 AM
    イベント ID: 12014
    タスク カテゴリ: TransportService
    レベル: エラー
    キーワード: クラシック
    ユーザー: N/A
    コンピューター: <HybridServerName.contoso.com>
    説明:
    Microsoft Exchange では、ローカル コンピューター上の個人用ストアで、ドメイン名 <I>CN=Certificate Name、OU=<CertificateIssuer>、O=US<S>CN=mail.contoso.com、OU=IT、O=contoso、L=location、S=location、C=US を含む証明書が見つかりませんでした。

  • オンプレミス サーバーへのチェック接続テストが失敗し、次のエラー メッセージが表示されます。

    450 4.4.101 プロキシ セッションのセットアップが Frontend で失敗し、'451 4.4.0 プライマリ ターゲット IP アドレスが "451 5.7.3 STARTTLS はメール送信に必要です" と応答しました。代替ホストへのフェールオーバーが試行されましたが、成功しませんでした。 代替ホストがないか、すべての代替ホストへの配信に失敗しました。 最後に試行されたエンドポイントは endpoint>'でした<。

原因

この問題は、ハイブリッド サーバーの受信コネクタのプロパティに、新しい Exchange 証明書がインストールされ、ハイブリッド メール フローに使用されている古い証明書が削除された後に正しくない証明書情報が含まれている場合 TlsCertificateName に発生します。

TlsCertificateName新しい Exchange 証明書のインストール後にハイブリッド構成ウィザード (HCW) を実行すると、プロパティが正しく設定されます。

ただし、HCW が実行されていない場合、または HCW の実行時に他の理由でエラーが発生した場合、 TlsCertificateName プロパティは更新されず、新しい Exchange 証明書はハイブリッド サーバーの受信コネクタで使用されません。

このシナリオでは、 STARTTLS コマンドが SMTP 通信に存在せず、Microsoft 365 からのメール フローは失敗します。

解決方法

新しい証明書が SMTP に対して有効になっていることを確認します。 そうでない場合は、次のコマンドを実行して、新しくインストールされた証明書で SMTP サービスを有効にします。

Enable-ExchangeCertificate <thumbprint> -services SMTP

注:

既定の証明書を上書きするように求められたら 、[いいえ ] を選択します)。 それ以外の場合、EdgeSync は中断され、再作成する必要があります。 次に、ハイブリッド サーバーの TlsCertificateName 受信コネクタから プロパティを削除します。 このためには、次のコマンドを実行します。

Get-ReceiveConnector "ServerName\Default Frontend ReceiveConnector" | Set-ReceiveConnector -TlsCertificateName $null

ハイブリッド構成ウィザードを再実行して、新しくインストールされた証明書情報を含むハイブリッド サーバー上の受信コネクタを更新します。

詳細

詳細については、「 ハイブリッド展開の証明書要件」を参照してください。

さらにヘルプが必要ですか? Microsoft コミュニティまたは Exchange TechNet フォーラムにアクセスしてください。