OneDrive または SharePoint の "403 Forbidden" エラー

現象

別のユーザーが共有する OneDrive または SharePoint Web サイトからファイルにアクセスしようとすると、次のエラー メッセージが表示されます。

エラー: 403 禁止

原因

"403 Forbidden" エラーは、次のいずれかの条件が原因で発生する可能性があります。

  • ブラウザー キャッシュをクリアする必要があります。

  • ファイルに対するアクセス許可がサーバー上で正しくレプリケートされていません。

  • OneDrive サイトがロックされています。

  • 問題は、organizationの SharePoint Online サービスに影響します。

解決方法

Microsoft 365 にサインインするときは、Web ブラウザーの使用可能なプライバシー モードを使用します。 たとえば、Microsoft Edge では InPrivate モード、Google Chrome ではシークレット モードを使用します。 次に、ファイルにアクセスしてみてください。 InPrivate ウィンドウを参照する方法については、「 Microsoft Edge」を参照してください。 シークレット ウィンドウを参照する方法については、「 Google Chrome」を参照してください。

プライバシー モードで参照しているときにファイルにアクセスできる場合は、ブラウザーのキャッシュをクリアします。 ブラウザー キャッシュをクリアする方法については、「 Edge または Chrome」を参照してください。

それでも問題が解決しない場合は、Organizationの SharePoint または OneDrive 管理者にお問い合わせください。 それが誰であるかがわからない場合は、「Microsoft 365 管理者操作方法見つける」を参照してください。

サードパーティの情報に関する免責事項

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。 明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

Microsoft では、このトピックに関する追加情報を見つけるのに役立つサード パーティの連絡先情報を提供しています。 将来予告なしに変更されることがあります。 Microsoft は、第三者の連絡先情報の正確性を保証しません。

管理者向けのアクション

キャッシュをクリアしても問題が解決しない場合は、次の方法を試してください。

ファイルを再共有する

ファイルのアクセス許可が正しくレプリケートされていないか、完全にレプリケートされていない可能性があります。 ファイルに再度アクセスする前に 30 分待つようユーザーに依頼します。 それでも 30 分後にエラーが発生する場合は、SharePoint Online および OneDrive for Business の 「SharePoint サイトにアクセスする場合」または「アクセス拒否」、"このサイトにアクセスするためのアクセス許可が必要です"、または "ディレクトリにユーザーが見つかりません" というエラーに記載されている手順を試してください。

OneDrive サイトがロックされているかどうかを確認する

ユーザーの OneDrive サイトがロックされた "NoAccess" 状態になっている可能性があります。 Microsoft 365 のグローバル管理者または SharePoint 管理者は、PowerShell を使用するか、Microsoft 365 Diagnostic を実行してサイトのロックを解除できます。 詳細については、「 SharePoint または OneDrive の読み取り専用エラー メッセージ」を参照してください。

サービスの正常性を確認する

管理者は、Microsoft 365 管理 センター[サービス正常性] ページ ([正常性>サービス正常性] に移動します。 発生している可能性のあるアドバイザリまたはインシデントを確認します。 SharePoint Online に対して発生するアドバイザリやインシデントがない場合は、[問題が利用可能な場合は 報告 する] を選択するか、Microsoft 365 テクニカル サポートで新しいサービス要求を開くことができます。

OneDrive サイトをプロビジョニングする

ユーザーがプロビジョニングされていない OneDrive サイトにアクセスしようとすると、エラー 403 が発生する可能性があります。 ユーザーに Microsoft 365 ポータルから OneDrive タイルへの移動を試みるようにします。

それでもうまくいかない場合は、 Request-SPOPersonalSite コマンドレットを使用してサイトをプロビジョニングします。

別のユーザーの OneDrive データにアクセスする

ユーザーが元従業員などの別のユーザーの OneDrive データにアクセスしようとしている場合は、「 手順 4 - 別の従業員に OneDrive と Outlook のデータへのアクセス権を付与する」の手順に従って、ユーザーにアクセス許可を付与できます。