エラー AADSTS650056 - 正しく構成されていないアプリケーション
この記事では、Microsoft Entra IDと統合された SAML ベースのシングル サインオン (SSO) 構成済みアプリにサインインしようとすると、次のエラー メッセージが表示される問題について説明します。
エラー AADSTS650056 - アプリケーションが正しく構成されていません。 これは、次のいずれかが原因である可能性があります。クライアントは、クライアントのアプリケーション登録で要求されたアクセス許可に '{name}' のアクセス許可を一覧表示していません。 または、管理者がテナントに同意していません。 または、要求のアプリケーション識別子をチェックして、構成されたクライアント アプリケーション識別子と一致することを確認します。 または、証明書を要求にチェックして、有効であることを確認します。 テナントの代わりに構成または同意を修正するには、管理者に問い合わせてください。 クライアント アプリ ID: {id}。 テナントの代わりに構成または同意を修正するには、管理者に問い合わせてください。
現象
SAML ベースの SSO を使用して ID 管理にMicrosoft Entra IDを使用するように設定されているアプリケーションにサインインしようとすると、エラーが発生AADSTS650056
します。
原因
アプリケーションから SAML 要求のMicrosoft Entra IDに送信される属性がIssuer
、Microsoft Entra IDでアプリケーション用に構成された Identifier 値と一致しません。
解決方法
SAML 要求の属性が、Issuer
Microsoft Entra IDで構成されている Identifier 値と一致していることを確認します。
[識別子] ボックスの値が、エラーに表示される識別子の値と一致することを確認します。
Issuer 属性の詳細については、「 単一 Sign-On SAML プロトコル」を参照してください。
詳細情報
Active Directory 認証エラー コードと承認エラー コードの完全な一覧については、「Microsoft Entra認証と承認のエラー コード」を参照してください。
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