InvalidResourceReference エラー コードのトラブルシューティング

この記事では、Microsoft Azure Kubernetes Service (AKS) クラスターを作成して展開したり、AKS クラスターを更新したりするときに発生する可能性があるエラーを特定して解決InvalidResourceReferenceする方法について説明します。

現象 1

AKS クラスターを作成しようとすると、次のエラー メッセージが表示されます。

Code="InvalidResourceReference"

Message="Resource
/subscriptions/<subscription-id-guid>/resourceGroups/MyResourceGroup/providers/Microsoft.Network/virtualNetworks/vnet-otcom/subnets/Subnet-AKS
リソースによって参照される
/subscriptions/<subscription-id-guid>/resourceGroups/MC_MyResourceGroup_MyCluster-AKS_JAPANEAST/providers/Microsoft.Compute/virtualMachineScaleSets/aks-nodepool-vmss
が見つかりませんでした。 参照先のリソースが存在し、両方のリソースが同じリージョンにあることを確認してください。

Details=[]

原因 1

この問題の考えられる原因を次に示します。

  • 異なるリージョン内のリソース間に不一致が存在します。

    現象 1 の例は、仮想ネットワークと仮想マシン スケール セットが同じリージョンにないことを示しています。 リソースは異なるリージョンにあるため、スケール セット インスタンスを作成することはできません。

  • 参照先のリソースが手動で変更または削除されました。

解決策 1

異なるリージョン内のリソース間に不一致が存在する場合は、リソースを確認して、それらが同じリージョンにあることを確認します。 この例では、AKS クラスターが構築されているリージョンを変更するか、同じリージョンに新しい仮想ネットワークを作成します。

参照先のリソースが手動で変更または削除された場合は、 MC_ リソース グループ 内の基になる IaaS リソースを手動で変更することはサポートされていないため、この問題を解決することが困難になる可能性があります。 考えられる解決策は、削除されたリソースを再作成し、VMSS と再関連付けしてから、AKS クラスターで更新プログラムをトリガーすることです。 ただし、これはサポートされていないシナリオであるため、このソリューションの成功を保証することはできません。

現象 2

AKS クラスターを更新しようとすると、次のエラー メッセージが表示されます。

Code="InvalidResourceReference"
Message="Resource
/subscriptions/<subscription-id-guid>/resourceGroups/MC_MyResourceGroup/providers/Microsoft.Network/loadBalancers/kubernetes/frontendIPConfigurations/<frontendIP_ID> resource /subscriptions/<subscription-id-guid>/resourceGroups/MC_MyResourceGroup/providers/Microsoft.Network/loadBalancers/kubernetes/loadBalancingRules/<frontend_IP_rule> が見つかりませんでした。 参照先のリソースが存在し、両方のリソースが同じリージョンにあることを確認してください。
Message="Resource

Details=[]

原因 2

この問題は、ロード バランサーの既定の送信規則 "aksOutboundRule" が手動で変更された場合に発生する可能性があります。 この予期しない変更は、通常、 パラメーターなしで load-balancer-outbound-ips クラスターを更新した場合に送信 IP が更新されるときに発生します。

解決策 2

パラメーターを az aks update 指定してコマンドを load-balancer-outbound-ips 再実行して、クラスターを更新します。 パラメーター値としてパブリック IP のリソース ID を使用します。 詳細については、「 独自の送信パブリック IP を使用してクラスターを更新する」を参照してください。

詳細

AKS クラスター作成に関する一般的なトラブルシューティング

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。