エラーコード 0x80090016 - イベント ビューアまたはエージェント ログにキーセットが存在しない。

Note

Log Analytics エージェント (Microsoft Monitoring Agent (MMA) とも呼ばれます) は、2024 年 8 月に廃止される予定。 その結果、Microsoft Defender for Cloud のマシン プラン上の Defender for Servers と Defender for SQL サーバーが更新され、Log Analytics エージェントに依存する機能が再設計されます。 詳細については、「Log Analytics エージェントの提供終了に向けた準備」を参照してください。

この記事では、イベント ビューアーまたはエージェント ログに接続しようとすると、エラー コード 0x80090016 - "Keyset は存在しません" を解決する方法について説明します。

現象

Microsoft Monitoring Agent (MMA) を使用して Log Analytics ワークスペースに接続しようとすると、接続が失敗し、次のいずれかのエラー エントリが Operations Manager イベント ビューアー ログに記録されます。

Event ID:      7022 
Description:   The Health Service has downloaded secure configuration for management
               group AOI-00000000-0000-0000-0000-000000000000, and processing the 
               configuration failed with error code Keyset does not exist(0x80090016). 
Event ID:      3009  
Description:   Loading the private key for the client authentication certificate for
               service "Log Analytics - ed4Customer-WorkspaceID" failed with error 
               "Keyset does not exist" (0x80090016). Connections to the service may
               be made without authentication. This can cause failures if the service
               requires the agent to be authenticated. The agent will continue to 
               periodically retry loading the authentication configuration.

原因

サーバーは、Windows Log Analytics エージェントが既にインストールおよび構成されているゴールデン イメージ (マスター イメージとも呼ばれます) から複製されました。 証明書に、Windows で現在使用されている名前ではなく、複製された元のサーバーの名前が含まれているため、接続に失敗します。 (Note: Log Analytics エージェントが既に構成されているコンピューターの複製はサポートされていません)。

解決策

これらのエラーを解決するには、次のように MMA 証明書をクリーンアップして更新します。

  1. サービス スナップインを開くには、 Start を選択し、「 services.msc」と入力して Enter キーを押します。

  2. サービスを停止するには、 Microsoft Monitoring Agent を選択し、 Stop Service アイコンを選択します。

  3. Microsoft 管理コンソール (MMC) を開くには、 Start を選択し、「 mmc.exe」と入力して Enter キーを押します。

  4. 証明書スナップインを追加するには、 File>Add/Remove Snap-in>Certificates>Add>Computer account>Next>Local computer>Finish>OK を選択します。

  5. MMC で既存の MMA 証明書を表示するには、 Certificates>Microsoft Monitoring Agent>Certificates に移動します。

  6. セキュリティと監査用のバックアップ コピーが用意されるように、各証明書をエクスポートすることをお勧めします。 これを行うには、次の手順を実行します。

    1. 一覧表示されている各証明書を個別に選択して右クリックし、[ すべてのタスク>Export>次へ>いいえ、 秘密キーをエクスポートしません

    2. Export ファイル形式 ページで、Base-64 でエンコードされた X.509 (.CER)>次へ

    3. [エクスポートするファイルの] ページの [ファイル名 フィールドに証明書ファイルの名前を入力し、証明書をエクスポートする場所に読み込みます。 次に、 Save>Next>Finish を選択します。

  7. 手順 6 の説明に従って中央のウィンドウに表示されている証明書のバックアップ コピーをエクスポートした後、MMC から証明書を削除します。 本体を開いたままにします。

  8. サービス スナップインで、 Microsoft Monitoring Agent を選択し、 Start Service アイコンを選択して再起動します。

  9. 1 分待ちます。 次に、MMC で [証明書] スナップインを選択し、更新する Refresh アイコンまたは F5 キーを押します。 新しい証明書が表示されます。

エージェント、イベント ログ、Log Analytics ワークスペースを観察して、これらの手順で問題が解決されたかどうかを判断します。

詳細

Microsoft Monitoring Agent のセットアップ

Log Analytics エージェントの概要: インストール オプション

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