エラー AADSTS50105 - サインインしているユーザーがアプリケーションのロールに割り当てられない
この記事では、Microsoft Entra IDを使用したフェデレーション認証中に発生するAADSTS50105 エラーの解決策について説明します。
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現象
SAML ベースのシングル Sign-On (SSO) を使用して ID 管理にMicrosoft Entra IDを使用するように設定されているアプリケーションにサインインしようとすると、次のエラー メッセージが表示されます。
エラー AADSTS50105 - サインインしているユーザーがアプリケーションのロールに割り当てられない。
原因
ユーザーには、Microsoft Entra IDでアプリケーションへのアクセス権が付与されていません。 ユーザーは、アプリケーションに割り当てられているグループに属しているか、直接割り当てられている必要があります。
注:
入れ子になったグループはサポートされていないため、グループをアプリケーションに直接割り当てる必要があります。
解決方法
1 人以上のユーザーをアプリケーションに直接割り当てるには、「クイック スタート: ユーザーをアプリに割り当てる」を参照してください。
詳細情報
Active Directory 認証エラー コードと承認エラー コードの完全な一覧については、「Microsoft Entra認証と承認のエラー コード」を参照してください。
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