エラー AADSTS70001 - 識別子を持つアプリケーションがディレクトリに見つかりませんでした
この記事では、Microsoft Entra IDと統合された SAML ベースのシングル サインオン (SSO) 構成済みアプリにサインインしようとすると、"エラー AADSTS70001 - 識別子を持つアプリケーションがディレクトリに見つかりませんでした" というエラー メッセージが表示される問題について説明します。
現象
SAML ベースの SSO を使用した ID 管理にMicrosoft Entra IDを使用するように設定されているアプリケーションにサインインしようとすると、エラーが発生AADSTS70001
します。
原因
アプリケーションから SAML 要求のMicrosoft Entra IDに送信される属性がIssuer
、Microsoft Entra IDでアプリケーション用に構成されている Identifier 値と一致しません。
解決方法
SAML 要求の属性が、Issuer
Microsoft Entra IDで構成されている Identifier 値と一致していることを確認します。
[SAML ベースの SSO 構成] ページの [ 基本的な SAML 構成 ] セクションで、[識別子] ボックスの値が、エラーに表示される識別子の値と一致することを確認します。 URL の末尾に末尾のスラッシュがある場合は、それも含める必要があります。
Microsoft Entra 管理センターでの SSO のテスト関数の使用
Microsoft Entra 管理センターは、SAML 構成エラーのトラブルシューティングに役立ちます。
- Microsoft Entra 管理センターで、[エンタープライズ アプリケーション] に移動し、トラブルシューティングが必要なアプリケーションをクリックします。
- 左側のナビゲーション メニューを使用して [ シングル サインオン ] ページに移動します
- [ このアプリケーションをテスト する] をクリックして、SSO のテスト機能を使用します。
- 受け取ったエラーをコピーして [エラーの解決] セクションに貼り付け、[解決ガイダンスの取得] をクリックします。
- 見つかった発行者と識別子の違いを表示します。
- 発行者または識別子を修正します。
詳細情報
Active Directory 認証と承認エラー コードの完全な一覧については、「認証と承認のエラー コードのMicrosoft Entra」を参照してください。
お問い合わせはこちらから
質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。