チャット ウィジェットがポータルに読み込まれない

この記事では、オムニチャネル for Customer Service のポータルでチャット ウィジェットが読み込まれない問題に関するいくつかの解決策について説明します。

現象

チャット ウィジェットがポータルに読み込まれません。

ポータルに表示されるチャット ウィジェットを示すスクリーンショット。

原因

構成によっては、この問題が発生する理由が複数あります。 この問題を解決するには、5 つの方法があります。

解決策 1: 場所オプション

チャット ウィジェットの [場所 ] オプションが正しく構成されていない可能性があります。

[ウィジェットの場所] で場所を削除し、再作成します。

チャット ウィジェットのウィジェットの場所 を削除して追加するには、次の手順に従います。

  1. オムニチャネル管理アプリにサインインします。

  2. [管理>チャット] に移動します

  3. 一覧からチャット ウィジェットを選択します。

  4. [ 場所 ] タブを選択します。

  5. [ ウィジェットの場所 ] セクションでレコードを選択し、[ 削除] を選択します。

  6. [保存] を選択します。

  7. [ウィジェットの場所] セクションで [追加] を選択して、レコードを追加します。 チャット ウィジェットの場所の簡易作成ウィンドウが表示されます。

  8. 次の詳細を指定します。

    フィールド
    タイトル レコードのタイトルを入力します。
    チャット ウィジェットを表示する必要がある Web サイト ドメイン。 ドメイン形式にプロトコル (http または https) を含めてはいけません。 たとえば、Web サイトは です https://contoso.microsoftcrmportals.com。 次に、値は です contoso.microsoftcrmportals.com
  9. [ 保存] を 選択してレコードを保存します。

  10. Web サイトに移動し、チャット ウィジェットが読み込まれるかどうかをチェックします。

注:

チャット ウィジェットでは、セッション ストレージとローカル ストレージがブラウザーで機能している必要があります。 これらのサービスが正常に動作するように、ブラウザーで Cookie が有効になっていることを確認します。

解決策 2: 場所を削除する

または、チャット ウィジェットの場所を削除してみてください。

チャット ウィジェットの場所を削除する方法を示すスクリーンショット。

解決策 3: ポータル キャッシュをクリアする

次の手順を実行して、ポータル キャッシュをクリアします。

  1. ポータルに移動し、ポータル管理者としてサインインします。

    ポータルに管理者としてサインインする方法を示すスクリーンショット。

  2. ポータル URL の末尾に次のテキストを追加します。

    /_services/about

    例:

    https://contoso.powerappsportals.com/_services/about

  3. [ キャッシュのクリア] を選択します

    [キャッシュのクリア] を選択してキャッシュをクリアする方法を示すスクリーンショット。

  4. ポータルを再読み込みします。

    また、Web ブラウザーでサード パーティの Cookie が許可されていることを確認してください。

解決策 4: ポータル構成を同期する

ポータル構成を同期するには、次の手順を実行します。

  1. Power Apps に移動します。

  2. ポータルを見つけて選択し、[編集] を選択 します

    Power Apps でポータルを編集する方法を示すスクリーンショット。

  3. [ 同期構成] を選択します

    [同期構成] を選択してポータル構成を同期する方法を示すスクリーンショット。

解決策 5: ポータルを再起動する

次の手順を実行して、ポータルを再起動します。

  1. Power Apps に移動します。

  2. ポータルを選択し、[詳細設定] で [設定の管理]> を選択します。

    ポータルの [詳細設定] オプション設定を示すスクリーンショット。

  3. [再起動] を選択します。

    [再起動] を選択してポータルを再起動します。