カスタマー サービスのオムニチャネルに通信パネルが読み込まれない

この記事では、コミュニケーション パネルが Customer Service アプリのオムニチャネルに読み込まれない問題の解決策について説明します。

現象

コミュニケーション パネルは、Customer Service 用オムニチャネル アプリに読み込まれません。

原因

次の場合、パネルは読み込まれません。

  • チャネル統合フレームワーク アプリにレコードが存在しません。
  • 構成は同期されません。

解決方法

この問題を解決するには:

  • 次の値を使用して Channel Integration Framework レコードを作成します。

    フィールド
    名前 オムニチャネル
    Label オムニチャネル
    チャネル URL <チャット コントロール cdn url>?uci=true&env=<env>&ocBaseUrl=<oc エンドポイント>&ucilib=<crm org url>/webresources/Widget/msdyn_ciLibrary.js
    送信通信を有効にする 不要
    チャネルの順序 0
    API バージョン 1.0
    チャネルの [統合インターフェイス アプリ] を選択します カスタマー サービスのオムニチャネル
    チャネルのロールを選択する
  • オムニチャネル管理者
  • オムニチャネル エージェント
  • オムニチャネルスーパーバイザー
  • レコードを作成する方法については、「Dynamics 365 organizationのチャネル プロバイダーを構成する」を参照してください。

  • 構成を同期するには、チャネルとロールを削除し、もう一度追加してレコードを保存します。

    1. Dynamics 365 アプリにサインインします。
    2. Dynamics 365のドロップダウン ボタンを選択し、[チャネル統合フレームワーク] を選択します。
    3. 一覧から オムニチャネル レコードを選択します。
    4. [チャネルの統合インターフェイス アプリの選択] セクションから Customer Service のオムニチャネルを削除します。
    5. [チャネルの統合インターフェイス アプリの選択] セクションに、Customer Service 用オムニチャネルをもう一度追加します。
    6. [チャネルのロールの選択] セクションからオムニチャネル エージェントオムニチャネル スーパーバイザーオムニチャネル管理者を削除します。
    7. [チャネルのロールの選択] セクションで、オムニチャネル エージェントオムニチャネル スーパーバイザーオムニチャネル管理者をもう一度追加します。
    8. [ 保存] を 選択してレコードを保存します。
    9. Customer Service 用オムニチャネル アプリにサインインし、通信パネルが読み込まれるかどうかをチェックします。