Microsoft Dynamics 365 App for Outlook にアクセスすると、サインイン時にエラー メッセージが表示される際に問題が発生しました

この記事では、Microsoft Dynamics 365 App for Outlook にアクセスするときに発生するエラーの解決策について説明します。

適用対象:Microsoft Dynamics 365 Customer Engagement Online
元の KB 番号: 3064194

現象

Outlook でDynamics 365 アプリ (アプリがサポートされている任意の場所) を選択すると、次のメッセージが表示されます。

サインイン中に問題が発生しました。 もう一度やり直してください。 問題が解決しない場合は、システム管理者に問い合わせてください。

原因

原因 1

Microsoft Dynamics 365 App for Outlook では、承認サービスに接続して、このアプリの使用が承認されていることを確認できませんでした。

原因 2

この問題は、Dynamics 365 App for Outlook のインストール後にDynamics 365 (オンライン) URL が変更された場合に発生する可能性があります。 たとえば、Dynamics 365 URL が<https://contosocorp.crm.dynamics.com>アプリをデプロイしたときに、その URL を後で に<https://contoso.crm.dynamics.com>変更した場合。

解決方法

解決方法 1

アプリを閉じて、もう一度開きます。 それでも問題が解決しない場合は、インターネット ブラウザーを閉じてからもう一度開いてみます。 問題が解決しない場合は、Dynamics 365 App for Outlook を使用して、"サインイン中に問題が発生しました" エラーの解決策をお試しください。

解決方法 2

Microsoft Dynamics 365 App for Outlook のインストール後にDynamics 365 (オンライン) URL を変更した場合は、アプリを再デプロイする必要があります。

  1. システム管理者ロールを持つユーザーは、Dynamics 365 Web アプリケーションを開き、[設定] 内の [Dynamics 365 App for Outlook] 領域に移動することで、アプリをユーザーに再デプロイできます。
  2. アプリを再デプロイする必要があるユーザーを選択し、[ アプリの追加] ボタンのいずれかを使用してアプリを再デプロイします。
  3. [状態] が [Outlook に追加] に変更された後、問題が解決されているかどうかを確認できます。 既にアプリを開いている場合は、閉じてもう一度開きます。

詳細

この問題が原因 2 の結果であるかどうかを確認するには、エラー メッセージの [ この問題を解決 する] リンクを右クリックし、URL をコピーします。 URL パラメーターを表示すると、古いDynamics 365 URL が含まれます。 前に示した例では、現在のDynamics 365 URL (contosocorp.crm.dynamics.com) ではなく、古い URL (contoso.crm.dynamics.com) が表示されます。