Microsoft Dynamics 365 App for Outlook で電子メールを開くときにビューが使用できないエラー
この記事では、Microsoft Dynamics 365 App for Outlook で電子メールを開こうとすると発生するビューが利用できないエラーを解決するための解決策を示します。
適用対象: Microsoft Dynamics CRM Online
元の KB 番号: 4338690
現象
Microsoft Dynamics 365 App for Outlook で電子メールを開くと、次のエラーが表示されます。
"ビューは使用できません。 システム管理者に問い合わせてください。
原因
このエラーは、Microsoft Dynamics 365 App for Outlook で使用されているビューの 1 つを非アクティブ化した場合に表示される可能性があります。 Microsoft Dynamics 365 App for Outlook では、特別なフォームを使用してリード (Outlook リード クイック ビュー用アプリ) または連絡先 (Outlook 連絡先クイック ビュー用アプリ) の情報を表示します。 これらの各フォームには、特定のビューを参照するリストが含まれています。 これらのビューのいずれかが非アクティブ化されている場合は、 ビューが使用できないエラーが 表示されることがあります。
解決方法
[App for Outlook リード クイック ビュー] フォームと [App for Outlook Contact Quick View] フォームで使用されるビューが非アクティブ化されていないことを確認します。 Microsoft Dynamics 365 App for Outlook で電子メールを表示する場合、使用されるフォームは、電子メールが潜在顧客または連絡先からのメールかどうかによって異なります。 メールが連絡先からの場合にのみこのエラーが表示される場合は、連絡先フォームで使用されるビューを修正するだけで済む場合があります。 メールがリードからの場合にのみエラーが表示される場合は、リード フォームで使用されるビューのみを修正する必要があります。 次の例では、App for Outlook Contact クイック ビュー フォームで使用される既定のビューがアクティブになっていることを確認します。 連絡先エンティティの代わりに潜在顧客エンティティの下にある Outlook リード クイック ビュー 用アプリ フォームにも同様の手順を使用できます。
- システム管理者またはシステム カスタマイザーのセキュリティ ロールを持つユーザーとして、Microsoft Dynamics 365 Web アプリケーションを開きます。
- [設定] に移動し、[カスタマイズ] を選択します。
- [ システムのカスタマイズ] を選択します。 [既定のソリューション] ダイアログが開きます。
- [ エンティティ] を選択し、[ 連絡先] を選択し、[フォーム] を選択 します。
- [App for Outlook Contact Quick View] フォームを開きます。 既定では、このフォームには、アクティビティの 2 つのリスト、営業案件のリスト、ケースのリストが含まれます。 次の表は、リストの既定の名前と、リストに使用される既定のビューを示しています。
- これらのテーブルは、既定のビューを再アクティブ化するための参照として使用できます。
- この例では、Activity エンティティからの最初の 2 つのリストを見ていきます。 上記の他のエンティティについても同じ手順を繰り返すことができます。
- [既定のソリューション] ダイアログに戻り、[アクティビティ] を選択し、[ビュー] を選択します。
- [ 表示 ] ドロップダウン リストを選択し、[ 非アクティブなパブリック ビュー] を選択します。
- [次のアクティビティ] ビューと [最後のアクティビティ] ビューが [非アクティブなパブリック ビュー] の一覧に表示されないことを確認します。 これらのビューのいずれかが非アクティブ化されている場合は、それらを選択し、[ アクティブ化] を選択します。
- 同じ手順を使用して他のビューがアクティブであることを確認したら、[ すべてのカスタマイズの発行] を選択します。
- Outlook を閉じて再度開き、ブラウザーのキャッシュをクリアする必要がある場合があります。
Outlook 連絡先クイック ビュー用アプリ
リスト名 | 既定のビュー | Entity |
---|---|---|
次のアクティビティ | 次のアクティビティ | アクティビティ |
最後のアクティビティ | 最後のアクティビティ | アクティビティ |
最近の機会 | 相互作用中心のフォームの最近の機会 | Opportunity |
最近のケース | アクティブなケース | ケース |
Outlook リード クイック ビュー フォーム用アプリ
リスト名 | 既定のビュー | Entity |
---|---|---|
次のアクティビティ | 次のアクティビティ | アクティビティ |
最後のアクティビティ | 最後のアクティビティ | アクティビティ |
ステーク ホルダー | すべての利害関係者 | Connection |
競合 他社 | すべての競合他社 (概要) | 競争 相手 |
注:
既定のビューをアクティブ化するのではなく、これらのフォームで使用するビューを変更する場合は、フォームのリスト セクションのプロパティを開いて、選択したビューを変更できます。 既定のビューの 1 つを非アクティブ化した場合、現在、その既定のビューを参照している場合でも、実際にはリストによって参照されているビューは表示されません。 代わりに、アクティブな他のビュー名が表示されます。 最初に別のビューに変更してから、変更を有効にするために選択したビューに変更する必要がある場合があります。
Microsoft では、ビューの変更中にエラーが発生する可能性がある問題を認識しています。 次のアクティビティ ビューと最後のアクティビティ ビューを変更できますが、他のビューを変更しようとするとエラーが発生します (エラーが発生しました。ホーム ページに戻り、やり直してください)。 Microsoft では、この問題に対する保護ソリューションを調査しています。