アプリ接続の設定時に認定パスの信頼アンカーが見つかりません

現象

サプライ チェーン管理に接続しようとすると、Warehouse Management アプリに次のエラー メッセージが表示されることがあります。

java.security.cert.certPathValidatorException: 認定パスのトラスト アンカーが見つかりません。

この問題は、次のプロパティを持つデバイスに影響する可能性があります。

  • OS バージョン: Android 4.4.x (Zebra TC55 など)。 これは、最近の Android バージョンでは問題ありません。
  • サプライ チェーン管理の場所: クラウド
  • 接続モード: クライアント シークレットまたは証明書

考えられる原因

Microsoft は、サプライ チェーン管理で使用されるサーバー SSL 証明書を更新している可能性があります。 その結果、ルート証明書や中間証明書のいずれかが変更された可能性があるため、新しい証明書はモバイル デバイスの信頼されたシステム証明書の一覧に表示されません。 新しいバージョンの Android では、信頼された証明書の一覧が自動的に更新されますが、Android 4.4.x では更新されません。

解決方法

この問題を解決するには、次のいずれかの操作を行います。

  • 次のセクションで説明する回避策を使用して、関連する各デバイスを更新します。
  • Zebra または Google に問い合わせて、システムの信頼された証明機関 (CA) 証明書の更新プログラムを取得できる 場合があります 。 ただし、これは確認されていません。
  • 可能であれば、古いデバイスを、より新しいバージョンの Android を実行しているデバイス (信頼された CA 証明書が自動的に更新される) に置き換えることを検討してください。

回避策

手順 1: Supply Chain Management から新しいルート証明書をエクスポートする

次の手順を実行して、インターネット ブラウザーを使用して新しいルート証明書を手動でダウンロードします。

  1. Dynamics Supply Chain Management にサインインし、フロント ページを開きます。
  2. ブラウザーのアドレス バーで、ロック アイコンを選択して 、[ 場所がセキュリティで保護 されている] ダイアログ ボックスを開きます。
  3. ダイアログ ボックスで、[ 証明書 (有効)] を選択して、その証明書の [証明書 ] ウィンドウを開きます。
  4. [証明書] ウィンドウの [認定パス] タブを開きます。
  5. 階層内に表示される上位の証明書を選択します。 (これはルート証明書です)。
  6. [証明書] ウィンドウの [詳細] タブを開きます。
  7. [詳細] タブの下部にある [ファイルにコピー] ボタンを選択します。
  8. 証明書のエクスポート ウィザードが開きます。 [次へ] を選んで続行します。
  9. [ ファイル形式のエクスポート] ページが開きます。 [DER でエンコードされたバイナリ X.509 (] を選択します。CER)。 次に、[ 次へ ] を選択して続行します。
  10. [ エクスポートするファイル] ページが開き、ファイル名と場所を指定します。 次に、[ 次へ ] を選択して続行します。
  11. [ 証明書のエクスポート ウィザードの完了 ] ページが開き、エクスポートの結果が表示されます。 [完了] を選択します。

手順 2: ダウンロードした証明書を影響を受けるデバイスにインストールする

次の手順に従って、ダウンロードした証明書をインストールします。

  1. 前の手順でダウンロードした証明書を、更新するデバイスに転送します。 たとえば、SD カードまたはネットワーク接続を使用して、デバイスでファイルを使用できるようにします。
  2. デバイスのセキュリティ設定を開き、メニュー オプションを選択してファイルから証明書をインストールします。 (この正確な手順は、デバイスと OS のバージョンによって異なります)。
  3. これで、信頼された証明書の [ ユーザー ] タブに新しい証明書が表示されます。
  4. 影響を受けるデバイスごとにこの手順を繰り返します。