クライアントがソフトウェア更新プログラムを取得しないConfiguration Manager

この記事では、Configuration Managerクライアントがソフトウェアの更新ポイントから更新プログラムを取得できない問題を修正します。

元の製品バージョン: Configuration Manager (現在のブランチ - バージョン 1702)
元の KB 番号: 4041012

現象

現在のブランチ バージョン 1702 Configuration Managerインストールすると、次のような現象が発生することがあります。

  • 新しくインストールされたクライアントは、ソフトウェアの更新ポイントから更新プログラムを取得できません。 これは、バージョン 1702 のインストール後にソフトウェアの更新ポイントが別のサーバーに移動された場合にも発生する可能性があります。 詳細なクライアント ログ記録が有効になっている場合、LocationServices.log ファイルにはエントリの空の値が WSUSLocationReply 含まれます。
  • 一部のコンピューターは、本体に [不明な状態] と表示されます。

原因

現在のブランチ バージョン 1702 Configuration Manager以降、クライアントは境界グループを使用して新しいソフトウェアの更新ポイントを見つけ、現在のソフトウェアの更新ポイントにアクセスできなくなった場合はフォールバックして新しいソフトウェアの更新ポイントを見つけます。 バージョン 1702 以降を実行する新しいサイトをインストールする場合は、クライアントがそれらを見つけて使用する前に、ソフトウェア更新ポイントを境界グループに割り当てる必要があります。

解決方法

ソフトウェア更新ポイントを実行しているサーバーを、クライアントの既定のサイト境界グループに追加します。 個々のソフトウェア更新ポイントを異なる境界グループに追加して、クライアントが見つけることができるサーバーを制御できます。 詳細については、「 ソフトウェアの更新ポイント」を参照してください。

ソフトウェアの更新ポイントを境界グループに追加するには、次の手順に従います。

  1. 存在しない場合は境界グループを作成し、ソフトウェアの更新ポイントをサイト サーバーとして使用して、すべてのクライアント マシンを境界グループに追加します。
  2. Configuration Managerでマシン ポリシー取得 & 評価サイクルを実行します。
  3. クライアント コンピューターのLocationServices.logを確認して、クライアントがWindows Server Update Services (WSUS) サーバーに接続できることを確認します。

注:

その後、多数のクライアントが WSUS サーバーに接続しようとすると、一時的なタイムアウトが発生する可能性があります。 これにより、WSUS サーバーで CPU 使用率が高くなる可能性もあります。 クライアントが接続すると、CPU 使用率は通常の状態に戻ります。 すべてのクライアントが接続された後も CPU 使用率が高い状態が続く場合は、「 WSUS サーバーでの CPU 使用率の高いトラブルシューティング」を参照してください。