Power Automate にデータ ゲートウェイがありません
Power Automate ポータルに 1 つ以上のオンプレミス データ ゲートウェイが表示されない場合は、この記事の推奨事項に従って問題を分離して解決してください。
適用先:Power Automate
元の KB 番号: 4555609
現象
Power Automate ポータルの [ゲートウェイ] ページには、1 つ以上のデータ ゲートウェイが表示されません。
原因
オンプレミス データ ゲートウェイをインストールしたリージョンが、Power Automate または Power Apps 環境が配置されているリージョンと一致しない場合、その環境でそのゲートウェイを表示または使用することはできません。
問題を確認する
問題を確認するには、まず使用している環境のリージョンをチェックし、Power Automate で目的の環境を選択していることを確認します。 次に、オンプレミス データ ゲートウェイのリージョンをチェックします。
手順 1: Power Apps 環境のリージョンを確認する
Power Platform 管理センターに管理者としてサインインします。
使用している環境のリージョンを確認します。
Power Automate にサインインし、目的の環境が選択されていることを確認します。
左側 の ナビゲーション ウィンドウで [ゲートウェイ] を選択します。
左側のナビゲーション ウィンドウにゲートウェイが表示されない場合は、[すべて検出する]> を選択し、[データ] で [ゲートウェイ] を見つけて、ナビゲーション ウィンドウにピン留めします。
ゲートウェイが表示されない場合は、手順 2 に進み、ゲートウェイのリージョンを確認します。
手順 2: ゲートウェイのリージョンを確認する
ゲートウェイをホストしているコンピューターで、[ スタート ] メニューに移動し、 オンプレミス データ ゲートウェイを検索して、アプリを起動します。
アプリの [状態] ページ で、[サインイン ] を選択し、ゲートウェイの作成時に使用した資格情報でサインインします。 資格情報を覚えていない場合は、[ 解決策 ] セクションに移動します。
サインインすると、ゲートウェイのリージョンが [状態] ページに表示されます。
注:
ゲートウェイがインストールされているリージョンは、Power Automate リージョンにマップする必要があります。 ゲートウェイリージョンと Power Platform リージョンのマッピングをチェックするには、「Power Automate のリージョンの概要」を参照してください。
リージョンが環境と一致しない場合は、「 解決策 」セクションの手順に従って問題を解決します。 リージョンがお使いの環境と一致する場合、または次の手順で問題が解決しない場合は、 Microsoft Power Automate サポート にお問い合わせください。
解決方法
既にインストールされているゲートウェイのリージョンを変更することはできません。 ただし、次の手順に従って、Power Automate 環境リージョンに一致するリージョンにゲートウェイを再インストールできます。
[ プログラムの追加と削除] に移動し、[ オンプレミス データ ゲートウェイ] を選択します。
[ アンインストール] を選択し、ウィザードに従ってゲートウェイをアンインストールします。
最新バージョンのオンプレミス Data Gateway インストーラーをダウンロードして実行します。 インストールする前に、最小限の要件と考慮事項については、「 オンプレミス データ ゲートウェイのインストール 」を参照してください。
ゲートウェイに名前を付ける手順に達するまで、インストール ウィザードに従います。 詳細なインストール手順については、「 オンプレミス データ ゲートウェイのインストール」を参照してください。
[リージョンの変更] リンク を選択 します。
Power Apps 環境に一致するリージョンを選択し、[完了] を選択 します。
注:
ゲートウェイがインストールされているリージョンは、Power Automate リージョンにマップする必要があります。 ゲートウェイリージョンと Power Platform リージョンのマッピングをチェックするには、「Power Automate のリージョンの概要」を参照してください。
完了するまでゲートウェイのインストール ウィザードに従います。
Power Automate にサインインし、左側のナビゲーション ウィンドウで [ゲートウェイ] を選択します。
ナビゲーション ウィンドウにゲートウェイが表示されない場合は、[すべて検出する]> を選択し、[データ] で [ゲートウェイ] を見つけて、ナビゲーション ウィンドウにピン留めします。
ゲートウェイがゲートウェイの一覧に表示されるかどうかを確認します。 ゲートウェイがまだ見つからない場合は、 Microsoft Power Automate サポート にお問い合わせください。