Salesforce CRM にオブジェクト アクセスがないため、レコードを更新できません

この記事は、Salesforce CRM のオブジェクト アクセスがないために、ユーザーが Microsoft Copilot for Sales の CRM レコードを更新できない場合の問題のトラブルシューティングと解決に役立ちます。

誰が影響を受けますか?

要件タイプ Description
クライアント アプリ Copilot for Sales Outlook アドイン
プラットフォーム Web およびデスクトップ クライアント
OS Windows および Mac
展開 ユーザー管理と管理者管理
CRM セールスフォース
ユーザー Copilot for Sales から CRM レコードを更新しようとしているユーザー

現象

ユーザーが Outlook 用 Copilot for Sales アドインから CRM レコードを更新しようとすると次のエラー メッセージが表示されます。

Salesforce を更新するには、このオブジェクトの編集アクセス権を要求します。

Salesforce CRM のオブジェクトアクセスが見つからないため、レコードを更新できないことに関するエラー。

原因

ユーザーは Salesforce のオブジェクトに対する編集アクセス権を持っていません。

ユーザーがオブジェクトを編集しようとすると、Copilot for Sales は、ユーザーが Salesforce のオブジェクトに Write アクセスできるかどうかを確認します。 ユーザーがオブジェクトへの 書き込み アクセス権を持っていない場合、エラー メッセージが表示されます。

ユーザーが Write エンティティへのアクセス権を持っていないかどうかを確認できます。ログに次のエラーが表示される場合は、問題の根本原因です。

Exception thrown in VivaSalesContacts/UpdateContact -  
Microsoft.SalesProductivity.Common.Base.SPServiceException: Salesforce failed to complete task: Message: entity is deleted clientRequestId:<CLIENT REQUEST ID>-self --->  
System.Exception: {  
    "status": 400,  
    "message": "Object type contact is not supported. If you are attempting to use a custom object, be sure to append the '__c' after the entity name.  
                Please reference your WSDL or the describe call for the appropriate names\r\nclientRequestId: <CLIENT REQUEST ID>-self",  
    "error": null,  
    "source": "Salesforce.Common",  
    "errors": []  
} 

上記のエラー メッセージで、Object type contact is not supportedは、ユーザーが Contact オブジェクトにWriteアクセスできないことを示しています。

解決方法

この問題を解決するには、次のものを持っていることを確認してください:

  • ユーザーが Salesforce で編集しようとしているオブジェクトに対する読み取りまたは書き込みレベルのアクセス許可。
  • 編集用に構成されたすべてのフィールドに対する読み取りまたは書き込みアクセス許可。

Salesforce のオブジェクト レベル セキュリティ、フィールド レベル セキュリティ、レコード レベル セキュリティについては、誰が何を閲覧するかを制御する を参照してください。 また、プロファイルのオブジェクト アクセス許可の設定 については、Salesforce 管理者にお問い合わせいただくこともできます。

詳細

問題がまだ解決しない場合は、 Copilot for Sales - Microsoft Community Hub にアクセスして、エキスパートと交流してください。

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