Salesforce CRM ユーザーが Copilot for Sales にデータを表示できない

この記事は、Microsoft Copilot for Sales でユーザーがデータを表示できない問題のトラブルシューティングと解決に役立ちます。

Note

Microsoft Sales Copilot は、2024 年 1 月に Microsoft Copilot for Sales としてブランド変更されました。 この記事のスクリーンショットは、近日中に新しい名前で更新されます。

誰が影響を受けますか?

要件タイプ Description
クライアント アプリ Copilot for Sales Outlook アドイン
プラットフォーム Web およびデスクトップ クライアント
OS Windows および Mac
展開 ユーザー管理と管理者管理
CRM セールスフォース
ユーザー Copilot for Sales フォームに追加されたフィールドを表示する権限がないユーザー

現象

Outlook で Copilot for Sales を開くと、次のエラー メッセージが表示されます。

問題が発生した場合

問題が発生したエラーの詳細を示すスクリーンショット。

原因

フィールドのフィールドレベルのセキュリティは、Salesforce CRM では非表示に設定されます。 その結果、Copilot for Sales では、構成でそのフィールドを想定どおりに参照できません。

解決策 1: Salesforce CRM のフィールド レベルのセキュリティを修正する

  1. Salesforce CRM に管理者としてサインインし、 Setup を開きます。

  2. オブジェクト マネージャー を開きます。

  3. エラーをスローしているエンティティを選択します。

  4. 左側のナビゲーション バーで、 フィールドとリレーションシップを選択します。

  5. エラーをスローしているフィールドを選択します。

  6. 上部にある フィールド レベルのセキュリティの設定 を選択します。

    Salesforce CRM のオブジェクト マネージャーを示すスクリーンショット。

  7. 適切なプロファイルに 表示 が選択されていることを確認します。

  8. カスタムのアクセス許可セットについても同様に検証します。

Salesforce CRM のフィールドレベルセキュリティの詳細については、「 フィールドレベルのセキュリティを参照してください。

解決策 2: Copilot for Sales の設定を変更してフィールドを非表示にするか、編集機能を削除する

Microsoft Teamsの Copilot for Sales 管理者設定から管理者設定を変更して、フィールドを非表示にするか、編集機能を削除します。

  1. テナント管理者の資格情報を使用して Microsoft Teams にサインインします。

  2. 左側のナビゲーション バーで、 [Sales のCopilot] を選択します。

  3. [ Settings タブで、 Forms を選択します。

  4. エラーが表示されているエンティティを選択します。

  5. フィールドの管理で、次のいずれかのアクションを実行します。

    • 問題がフィールドの編集に関連している場合は、対応するフィールドの Allow 編集 をオフにします。

      [フィールドの管理] ページで、いくつかのフィールドの編集をオフにする方法を示すスクリーンショット。

    • 問題がフィールドの表示に関連している場合は、フィールドの上にマウス ポインターを合わせ、 Remove フィールド ( ) を選択します。

  6. 公開 を選択して、変更を保存します。

解決策 3: CRM からデータを更新する

問題の原因となっているフィールドがわからない場合は、CRM からデータ参照できます。 このアクションにより、CRM から Sales 用の Copilot への最新の変更が同期され、CRM から削除されたが、Copilot for Sales で引き続き使用できるフィールドが削除されます。 データを更新したら、Outlook で Copilot for Sales アドインを閉じてから再度開く必要があります。

詳細

問題がまだ解決しない場合は、 Copilot for Sales - Microsoft Community Hub にアクセスして、エキスパートと交流してください。

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