ADAL 및 AD FS가 비즈니스용 Skype 사용되는 경우 SSO를 사용하여 로그인할 수 없습니다.

원래 KB 번호: 4508931

증상

ADAL(Azure Active Directory 인증 라이브러리) 및 AD FS(Active Directory Federation Services)를 사용하는 경우 새 사용자는 SSO(Single Sign-On) 메서드를 사용하여 Microsoft 비즈니스용 Skype 온-프레미스에 로그인할 수 없습니다.

기존 프로필은 이 문제의 영향을 받지 않습니다. 로그인을 시도하는 동안 프로필을 삭제한 새 사용자 또는 사용자는 다음 오류 메시지를 받습니다.

오류 발생.

이 문제는 사용자 프로필이 만들어지지 않은 경우 새로 이미지된 컴퓨터에서도 발생합니다.

원인

이 문제는 Microsoft Office 2016 버전 16.0.7967.0000 이상 버전으로 업그레이드한 후 기본 인증 방법이 WAM(웹 계정 관리자)으로 변경되므로 발생합니다.

해결 방법

중요

주의를 기울여 이 절의 단계를 수행하십시오. 레지스트리를 잘못 수정하는 경우 심각한 문제가 발생할 수 있습니다. 문제가 발생할 경우 복원을 위해 레지스트리를 백업합니다.

다음 레지스트리 키 중 하나를 추가합니다.

  • EnableWAM 이 하위 키에 키를 추가합니다.

    HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Office\16.0\Lync

    이름: EnableWAM
    형식: DWORD(32비트)
    값: 0x00000000

  • EnableWAM 이 하위 키에 키를 추가합니다.

    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Office\16.0\Lync

    이름: EnableWAM
    형식: DWORD(32비트)
    값: 0x00000000

  • DisableADALatopWAM 이 하위 키에 키를 추가합니다.

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity

    이름: DisableADALatopWAM
    형식: DWORD(32비트)
    값: 1

    참고

    동일한 위치에 이름이 DisableADALatopWAMOverride 비슷한 키가 있습니다. 이 키는 비즈니스용 Skype 사용되지 않습니다. 이 옵션을 선택하는 경우 를 사용합니다 DisableADALatopWAM .

추가 정보

이 문제를 방지하려면 최신 하이브리드 인증을 사용합니다. 자세한 내용은 하이브리드 최신 인증 개요 및 온-프레미스 비즈니스용 Skype 및 Exchange 서버와 함께 사용하기 위한 필수 조건을 참조하세요.