Android Enterprise 디바이스를 다시 설정한 후에는 공장 초기화 보호 전자 메일 설정이 적용되지 않습니다.

이 문서에서는 등록된 Android Enterprise 디바이스 소유자 디바이스에 대해 공장 초기화 보호 이메일 설정이 예상대로 작동하지 않는 문제에 대한 솔루션을 제공합니다.

증상

다음과 같은 경우를 생각해볼 수 있습니다.

  • Microsoft Intune 등록된 Android Enterprise 디바이스가 있습니다.

  • 다음 스크린샷 과 같이 공장 초기화 보호 이메일 설정이 활성화되고 이메일 주소가 제공됩니다.

    팩터리 초기화 보호 이메일 설정 및 샘플 이메일 주소의 스크린샷

  • 설정 메뉴(예: 설정일반 관리>> 공장데이터 재설정을 탭)>를 통해 디바이스에서 공장 초기화를 수행하거나 Microsoft Intune 관리 센터의 Intune 디바이스를 초기화합니다.

이 시나리오에서는 공장 초기화 보호 이메일 설정에 포함되지 않은 Google 계정을 사용하여 디바이스를 활성화할 수 있습니다.

원인

이 동작은 예상한 것입니다. 설정 메뉴를 통해 디바이스에서 공장 초기화를 수행하거나 Microsoft Intune 관리 센터의 Intune 디바이스를 초기화하면 모든 데이터가 제거됩니다. 여기에는 FRP(공장 초기화 보호) 데이터가 포함됩니다.

해결 방법

FRP 데이터를 잃지 않고 디바이스에서 공장 초기화를 수행하는 유일한 방법은 복구 모드를 사용하는 것입니다.

사용자가 디바이스 설정에서 공장 초기화 옵션을 사용하지 못하도록 팩터리 재설정 값을 차단 으로 설정하는 것이 좋습니다.

공장 초기화 옵션의 스크린샷.

그런 다음, 디바이스를 공장 설정으로 다시 설정할 때 다음 방법 중 하나를 사용합니다.

  • 복구 모드를 통해 디바이스를 다시 설정합니다.
  • 디바이스가 소유 중이고 추가 사용을 위해 다시 설정될 것으로 예상되는 경우 Intune 디바이스를 초기화합니다.