KRB_AP_ERR_TKT_EXPIRED erro em bilhetes Kerberos
Este artigo ajuda-o a resolver problemas de autenticação consistentes que podem afetar os pedidos kerberos.
O Kerberos é um protocolo que utiliza chaves secretas para fornecer autenticação segura para aplicações cliente ou servidor. É emitido um pedido de suporte a um utilizador para autenticação com êxito. Normalmente, os bilhetes Kerberos têm uma duração de cerca de 10 horas e são renovados automaticamente.
Sintomas
O Centro de Distribuição de Chaves (KDC) apresenta uma KRB_AP_ERR_TKT_EXPIRED
mensagem de erro que indica que um serviço falhou.
Motivo
A ligação Kerberos falha se um utilizador tentar utilizar um pedido de autenticação expirado. Para obter mais informações, veja Kerberos authentication troubleshooting guidance (Documentação de orientação para a resolução de problemas de autenticação Kerberos).
Solução
Para resolver esse erro, siga estas etapas:
Utilize o
KLIST purge
comando para limpar permissões de utilizador, terminar e voltar a iniciar sessão ou reiniciar o computador.Utilize o
KLIST
comando juntamente com a ferramenta SSPIClient para ver e gerir permissões Kerberos e nomes de principais de serviço (SPNs), conforme mostrado no seguinte comando:KLIST GET MSSQLSvc\SQLProd01.contoso.com:1433