Ativação do Windows - ID duplicado da máquina cliente

Aplica-se a: ✔️ Windows VMs

Geralmente, recomendamos o uso de servidores KMS (Serviços de Gerenciamento de Chaves) do Azure para ativar VMs (máquinas virtuais) do Azure Windows, mesmo quando o Benefício Híbrido do Azure está habilitado. No entanto, em casos específicos, como as restrições de rede podem impedir que as VMs se comuniquem com servidores KMS do Azure, você pode usar um servidor KMS auto-hospedado para ativação. Este artigo discute um problema de ID de máquina cliente duplicada que ocorre quando você usa um servidor KMS auto-hospedado para ativação do Windows e fornece uma solução.

Observação

Este artigo se aplica somente quando você usa um servidor KMS auto-hospedado para ativação. Ele não se aplica quando você usa o KMS do Azure para ativação.

Sintomas

Quando você usa um servidor KMS auto-hospedado para ativação e tenta ativar mais de uma VM do Windows Server, a ativação falha após o período de avaliação e o servidor KMS auto-hospedado relata o seguinte erro no Relatório de ID do Computador Cliente Duplicado:

O Relatório de ID de Computador Cliente Duplicado ajuda a identificar computadores no ambiente que estão executando imagens que não foram generalizadas corretamente usando a ferramenta Sysprep antes da implantação.
Observação:
- Vários clientes de ativação de volume com o mesmo CMID serão contados como um único cliente pelo KMS. Se isso fizer com que a contagem de clientes do KMS fique abaixo do limite mínimo, a ativação do KMS falhará em seu ambiente.

Causa

  • A ID do computador cliente (CMID) é limpa durante o processo Sysprep da imagem de origem original. No entanto, se o processo Sysprep for disparado com o parâmetro SkipRearm definido como 1 em vez do valor padrão de 0, o CMID não será limpo. Nesse caso, todas as VMs criadas a partir dessa imagem terão o mesmo CMID.

  • Quando você cria VMs do Azure Marketplace, as imagens do Azure Marketplace para Windows Server são generalizadas com o parâmetro SkipRearm definido como 1. Portanto, as VMs criadas usando a mesma imagem do Windows Server terão o mesmo CMID.

Confirmar CMID duplicado

Verifique se as VMs têm o mesmo CMID com base na imagem e na versão de origem:

  1. Execute o seguinte comando nas VMs problemáticas:

    cscript C:\Windows\System32\slmgr.vbs /dlv
    

    Aqui está um exemplo de saída de comando:

    Most recent activation information:
    Key Management Service client information
        Client Machine ID (CMID): <client-machine-ID>
        Registered KMS machine name: <KMS-machine-name>
    
  2. Compare as saídas de comando nas VMs problemáticas e confirme se as VMs têm o mesmo CMID.

Solução

  • Para as VMs problemáticas criadas a partir de uma imagem personalizada, generalize/sysprep a VM original com o parâmetro SkipRearm definido como 0 para garantir que o CMID seja limpo da imagem.

  • Para as VMs problemáticas que já estão implantadas, siga estas etapas:

    1. Execute o comando slmgr /rearm de um prompt de comandos com privilégios elevados.

    2. Reinicie a VM.

    3. Depois que a VM estiver online após a reinicialização, execute o seguinte comando para confirmar se o CMID foi alterado:

      cscript C:\Windows\System32\slmgr.vbs /dlv
      
    4. Acione a ativação novamente.

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.