Ошибка AADSTS750054 — SAMLRequest или SAMLResponse должны присутствовать в качестве параметров строки запроса в HTTP-запросе для привязки перенаправления SAML.

В этой статье описывается проблема, из-за которой при попытке входа в приложение, настроенное на основе SAML, интегрированное с Microsoft Entra ID, появляется сообщение об ошибке "Ошибка AADSTS750054 — SAMLRequest или SAMLResponse должно присутствовать в качестве параметров строки запроса в HTTP-запросе для привязки перенаправления SAML".

Симптомы

При попытке входа в приложение, настроенное на использование Microsoft Entra ID для управления удостоверениями с помощью единого входа на основе SAML, появляется сообщение об ошибкеAADSTS750054.

Причина

Microsoft Entra ID не удалось определить запрос SAML в параметрах URL-адреса в HTTP-запросе. Это может произойти, если приложение не использует привязку перенаправления HTTP при отправке запроса SAML в Microsoft Entra ID.

Разрешение

Приложению необходимо отправить запрос SAML, закодированный в заголовок расположения, с помощью привязки перенаправления HTTP. Дополнительные сведения о его реализации см. в разделе Привязка перенаправления HTTP в документе спецификации протокола SAML.

Чаще всего ошибка возникает из-за одной из следующих проблем:

  1. Убедитесь, что на стороне приложения включен единый вход.
  2. Приложение должно поддерживать единый вход, инициированный поставщиком услуг (иногда называемый единым входом, инициированным поставщиком услуг). При вводе URL-адреса для входа в приложение, которое поддерживает только инициированный поставщиком удостоверений единый вход, может привести к отказу от приложения без ответа SAML.
  3. Убедитесь, что URL-адрес входа настроен правильно.

Использование функции тестового единого входа в Центр администрирования Microsoft Entra

Центр администрирования Microsoft Entra поможет устранить ошибки конфигурации SAML.

Снимок экрана: тестирование функции единого входа в Центр администрирования Microsoft Entra.

  1. В Центр администрирования Microsoft Entra перейдите в раздел Корпоративные приложения и щелкните приложение, которое требует устранения неполадок.
  2. Перейдите на страницу единого входа с помощью меню навигации слева.
  3. Щелкните Тестировать приложение , чтобы использовать функцию "Тестировать единый вход".
  4. Скопируйте и вставьте полученную ошибку в раздел Устранение ошибок и щелкните Получить руководство по устранению неполадок.
  5. Выполните действия, чтобы устранить ошибку AADSTS750054

Дополнительные сведения

Полный список кодов ошибок проверки подлинности и авторизации Active Directory см. в разделе Microsoft Entra коды ошибок проверки подлинности и авторизации.

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.