Ошибка: "Веб-сокет закрыт или не удается открыть"
В этой статье описывается, как устранить сообщение об ошибке "Веб-сокет закрыт или не удается открыть", которое препятствует подключению Экземпляры контейнеров Azure Майкрософт к виртуальной сети.
Симптомы
При попытке подключиться к контейнеру из портал Azure появляется следующее сообщение об ошибке:
Произошла следующая ошибка веб-сокета: "Веб-сокет закрыт или не удалось открыть". Проверьте сетевое подключение и повторите попытку.
Причина
Брандмауэр блокирует доступ к порту 19390. Этот порт необходим для подключения к Экземпляры контейнеров из портал Azure при развертывании групп контейнеров в виртуальных сетях.
Решение
Разрешите входящий трафик через TCP-порт 19390 в брандмауэре. Как минимум, убедитесь, что брандмауэр предоставляет доступ к этому порту для всех общедоступных IP-адресов клиентов, к которым должен подключиться портал Azure.
Свяжитесь с нами для получения помощи
Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.