Сбой резервного копирования состояния системы агента служб восстановления Microsoft Azure (идентификатор ошибки 8007007B)
В этой статье описаны симптомы и способы устранения ошибки, возникающей при резервном копировании состояния системы с помощью агента служб восстановления Microsoft Azure (MARS).
Исходная версия продукта: Azure Backup
Исходный номер базы знаний: 4053355
Симптомы
Одно из следующих сообщений об ошибках отображается на вкладке Ошибки диалогового окна Сведения о задании , которое соответствует сбою задания резервного копирования состояния системы в консоли агента служб восстановления Microsoft Azure.
Не удалось выполнить операцию, так как задание резервного копирования Windows Server завершилось сбоем с сообщением об ошибке: Ни один из элементов, включенных в резервную копию, не был выполнен. Подробная ошибка: неправильный синтаксис имени файла, каталога или метки тома HResult: 80780049 DetailedHResult: 8007007B Goto https://go.microsoft.com/fwlink/?linkid=847810 , чтобы устранить эту проблему. (0x1873D)
Windows Server не удалось создать резервную копию состояния системы, так как системный модуль записи сообщил о недопустимом пути. Сообщение об ошибке windows Server Backup: неправильное имя файла, имя каталога или метка тома HResult: 80780049 DetailedHResult: 8007007B Goto https://go.microsoft.com/fwlink/?linkid=859092 , чтобы исправить это. (0x18770)
Если щелкнуть Журналы сбоев WSB, откроется файл, содержащий сообщение об ошибке, похожее на следующее:
Ошибка при резервном копировании перечисления Systemroot_pathduring: ошибка [0x8007007b] Неправильный синтаксис имени файла, каталога или метки тома.
Причина
Эта ошибка возникает, когда спецификация файла, необходимая для перечисления файлов, резервные копии для резервного копирования в системном состоянии Windows Server, обновляется неправильно.
Разрешение
Предупреждение
При неправильном изменении реестра с использованием редактора реестра или другого способа могут случиться серьезные проблемы. Для решения этих проблем может потребоваться переустановка операционной системы. Компания Microsoft не может гарантировать, что эти проблемы могут быть решены. Вносите изменения в реестр на ваш страх и риск.
Чтобы убедиться, что спецификация файла обновлена, выполните следующие действия.
В файле, который открывается при нажатии кнопки Журналы сбоев WSB, проверьте правильность Systemroot_path . Например, Systemroot_path в следующем сообщении об ошибке должно выглядеть так:
C:\Windows\\systemroot\
Ошибка при резервном копировании c:\windows\systemroot\ во время перечисления: Ошибка [0x8007007b] Неправильный синтаксис имени файла, имени каталога или метки тома.
Выполните следующую команду в командной строке с повышенными привилегиями:
diskshadow /l Output_File_Path
Примечание.
Заполнитель Output_File_Path должен выглядеть так:
C:\outputfilepath.txt
.Введите следующие команды в командной строке DISKSHADOW и нажмите клавишу ВВОД после каждой команды:
list writers detailed exit
Откройте выходной файл, указанный на шаге 2.
Найдите строку, содержащую Systemroot_path (
C:\Windows\\systemroot\
в приведенном выше примере). Например, строка должна выглядеть следующим образом: File List: Path = Systemroot_path\system32\drivers, Filespec = File_Spec_PathНапример:
Список файлов: путь =
C:\windows\\systemroot\system32\drivers
, Filespec = winmad.sysОткройте редактор реестра. Для этого щелкните правой кнопкой мыши Пуск, выберите команду Выполнить, введите regedit в поле Открыть и нажмите кнопку ОК.
Найдите следующий подраздел:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
Щелкните правой кнопкой мыши Службы, а затем выберите найти.
В поле Найти введите путь File_Spec_Path , найденный на шаге 5, и нажмите кнопку Найти далее.
Пример:
В результатах поиска будет указан раздел реестра с именем ImagePath. Если его значение имеет начальную обратную косую черту "", дважды щелкните это значение и удалите его. Если значение не начинается с обратной косой черты, отправьте запрос на поддержку от портал Azure.
Перед изменением После изменения Назад в консоль агента MARS и запустите резервное копирование состояния системы, щелкнув Создать резервную копию.
Свяжитесь с нами для получения помощи
Если у вас есть вопросы или вам нужна помощь, создайте запрос в службу поддержки или обратитесь за поддержкой сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.