Отображение в Windows уведомления "Проверка файловой системы" при загрузке виртуальной машины Azure

Область применения: ✔️ Виртуальные машины Windows

В этой статье описывается ошибка "Проверка файловой системы", которая может возникнуть при загрузке виртуальной машины Windows в Microsoft Azure.

Симптом

Виртуальная машина Windows не запускается. Когда вы проверяете скриншоты загрузки в окне Диагностика загрузки, видно, что процесс "Проверка диска" (chkdsk.exe) работает с одним из следующих сообщений.

  • Проверка и восстановление диска (C:)
  • Проверка файловой системы на диске С.

Причина

Если в файловой системе обнаружена ошибка NTFS, Windows проверит и восстановит согласованность диска при следующем перезапуске. Обычно это происходит, если у виртуальной машины был неожиданный перезапуск, или если процесс ее завершения был прерван.

Решение

Совет

Если у вас есть последняя резервная копия виртуальной машины, попробуйте восстановить виртуальную машину из резервной копии , чтобы устранить проблему загрузки.

Windows будет загружаться нормально после завершения процесса проверки диска. Если виртуальная машина зависает в процессе проверки диска, попробуйте запустить проверку диска на виртуальной машине в автономном режиме.

  1. Сделайте снимок диска ОС затронутой виртуальной машины в качестве резервной копии. Дополнительные сведения см. в статье Создание моментального снимка.

  2. Подключите диск ОС к виртуальной машине восстановления.

  3. На виртуальной машине восстановления выполните проверку диска на подключенном диске ОС. В следующем примере имя драйвера подключенного диска ОС является папка E.

    chkdsk E: /f
    
  4. После завершения проверки диска отсоедините диск от виртуальной машины восстановления, а затем повторно подключите диск к затронутой виртуальной машине в качестве диска ОС. Дополнительные сведения см. в статье "Устранение неполадок с виртуальной машиной Windows" путем подключения диска ОС к виртуальной машине восстановления через портал Azure.

Свяжитесь с нами для получения помощи

Если у вас есть вопросы или помощь, создайте запрос на поддержку или попросите сообщества Azure. Вы также можете отправить отзыв о продукте в сообщество отзывов Azure.