SharePoint Online ve OneDrive'da "Erişim Reddedildi" veya "İzin gerekiyor" hataları

Belirtiler

Kullanıcılar, SharePoint Online veya OneDrive İş sitesine erişmeyi denediklerinde aşağıdaki hata iletilerinden birini alırlar:

  • Erişim Reddedildi
  • Bu siteye erişim için izin gerekiyor
  • Kullanıcı, dizinde bulunamadı

Kullanıcılar, SharePoint Online veya OneDrive sitelerinden diğer kullanıcılar tarafından paylaşılan dosyaların veya klasörlerin bağlantılarına erişmeye çalıştığında aşağıdaki hata iletisini alır:

Bu bağlantı sizin için kullanılabilir değil.
Özür dileriz, şu anda olarak oturum açtınız ancak bu hesap bunun güvenli olarak kullanıma sunulduğu kişiler listesinde yer almıyor. Farklı bir e-posta denemek için lütfen oturumu kapatın ve bağlantıyı yeniden açın.

Neden

Bu hatalar aşağıdakiler gibi çeşitli nedenlerle oluşabilir:

  • Etkilenen kullanıcının izinleri doğru yapılandırılmamıştır.
  • Paylaşılan bağlantıya erişmek için kullanılan hesap, paylaşım davetinin gönderildiği hesaptan farklıdır.
  • Site kullanıcı kimliği uyuşmazlığı. Kimlik uyuşmazlığı genellikle bir kullanıcı hesabı Microsoft 365 yönetim merkezinden silinirse ve ardından silinen hesap tarafından kullanılmış olan kullanıcı asıl adı (UPN) kullanılarak yeni bir hesap oluşturulursa ortaya çıkar. UPN aynı olsa bile yeni hesaba yeni bir kimlik değeri atanır. Kullanıcılar SharePoint'te zaten oturum açmış ve daha sonra farklı bir kuruluş birimine (OU) taşınmışsa, Active Directory kuruluş birimi ile SharePoint arasındaki dizin eşitlemesi sırasında da uyuşmazlık oluşabilir.

Çözüm seçeneği 1: Kullanıcı Erişimini Denetle tanılamasını çalıştırma

Not

Bu tanılama GCC High veya DoD ortamlarında veya 21Vianet tarafından sağlanan Microsoft 365'de kullanılamaz.

Microsoft 365 yöneticileri, kullanıcı erişimini etkileyen olası sorunları belirlemek için kiracı içinde tanılamayı çalıştırabilir.

Microsoft 365 yönetim merkezindeki tanılamayı dolduran aşağıdaki Testleri Çalıştır düğmesini seçin.

Tanılama işlemi, SharePoint ve OneDrive sitelerine erişmeye çalışan iç kullanıcılar veya konuklar için çok çeşitli doğrulamalar gerçekleştirir.

Çözüm seçeneği 2: El ile düzeltme

Erişim sorunlarını el ile düzeltmek için ilgili senaryonun adımlarını izleyin.

Kullanıcı SharePoint sitesine veya başka bir kullanıcının OneDrive sitesine erişemiyor

  1. Kullanıcının sitede sahip olması gereken izin düzeyini belirleyin.

  2. İzinleri Denetleyin özelliğini kullanarak izni doğrulayın:

    1. SharePoint sitesi için Ayarlar >Site izinleri'ne tıklayın. OneDrive sitesi için Ayarlar> Site Ayarları>Site izinleri'ne tıklayın.
    2. Şeritte, İzinleri Denetle'yi seçin.
    3. Kullanıcı/Grup alanına kullanıcının adını girin ve sonra Şimdi Denetle'yi seçin.
    4. Kullanıcının sitede sahip olduğu izinleri gözden geçirin ve ilgili güvenlik grubunu (varsa) da denetleyin.
  3. Kullanıcının uygun izinleri yoksa dosya veya site için kullanıcıya izinler verin.

  4. Kullanıcı, hata iletisi almaya devam ederse siteden kullanıcıyı kaldırın. Ardından kullanıcıya dosya veya site izinlerini verin.

    Not: Konuk hesabı hala hatalardan etkileniyorsa, ziyaretçi hesabını Microsoft 365 yönetim merkezinden tamamen kaldırmanızı öneririz. Kullanıcının site koleksiyonundan kaldırıldığından emin olun. Ardından kullanıcıya dosya veya site izinlerini verin.

Kullanıcı kendi OneDrive sitesine erişemiyor

Bu sorun genellikle site kullanıcı kimliği uyuşmazlığı nedeniyle ortaya çıkar.

Sorunu düzeltmek için yeni bir UPN olup olmadığını denetleyin. Eğer varsa yeni UPN'yi silin ve ardından özgün UPN'yi geri yükleyin.

Bu yordamı kullanmak konusunda rahat değilseniz, sorunu düzeltmeye yönelik otomatik bir çözüm için bkz. SharePoint veya OneDrive'da site kullanıcı kimliği uyuşmazlığını düzeltme.

Etkilenen kullanıcıyı siteden kaldırın ve sonra dosyayı veya klasörü yeniden paylaşın.