错误AADSTS50003 - 未配置签名密钥
本文介绍在尝试登录到已与 Microsoft Entra ID 集成的基于 SAML 的单一登录 (SSO) 配置的应用时收到错误消息“AADSTS50003错误 - 未配置签名密钥”。
症状
尝试登录到已设置为使用 Microsoft Entra ID 使用基于 SAML 的 SSO 进行标识管理的应用程序时收到错误AADSTS50003
。
原因
应用程序对象已损坏,Microsoft Entra ID无法识别为应用程序配置的证书。
解决方案
若要删除并创建新证书,请执行以下步骤:
- 在“基于 SAML 的 SSO 配置”屏幕上,选择“SAML 签名证书”部分下的“创建新证书”。
- 选择“到期日期”,然后单击“ 保存”。
- 选中 “使新证书处于活动状态 ”以覆盖活动证书。 然后,单击窗格顶部的“ 保存 并接受”以激活滚动更新证书。
- 在“ SAML 签名证书 ”部分下,单击“ 删除 ”以删除 未使用的 证书。
更多信息
有关 Active Directory 身份验证和授权错误代码的完整列表,请参阅Microsoft Entra身份验证和授权错误代码
联系我们寻求帮助
如果你有任何疑问或需要帮助,请创建支持请求或联系 Azure 社区支持。 还可以向 Azure 反馈社区提交产品反馈。