错误AADSTS750054 - SAMLRequest 或 SAMLResponse 必须作为 SAML 重定向绑定的 HTTP 请求中的查询字符串参数存在
本文介绍了以下问题:尝试登录到已与 Microsoft Entra ID 集成的基于 SAML 的单一登录 (SSO) 配置的应用时,收到错误消息“错误AADSTS750054 - SAMLRequest 或 SAMLResponse 必须作为查询字符串参数出现在 SAML 重定向绑定的 HTTP 请求中”。
症状
尝试登录到已设置为使用 Microsoft Entra ID 使用基于 SAML 的 SSO 进行标识管理的应用程序时收到错误AADSTS750054
。
原因
Microsoft Entra ID无法在 HTTP 请求的 URL 参数中标识 SAML 请求。 如果应用程序在向Microsoft Entra ID发送 SAML 请求时未使用 HTTP 重定向绑定,则可能会发生这种情况。
解决方案
应用程序需要使用 HTTP 重定向绑定发送编码到位置标头中的 SAML 请求。 有关如何实现它的详细信息,请阅读 SAML 协议规范文档中的 HTTP 重定向绑定部分。
大多数情况下,错误是由以下问题之一引起的:
- 确保在应用程序端启用了单一登录。
- 应用程序必须支持服务提供商发起的单一登录 (有时称为 SP 发起的 SSO) 。 为仅支持标识提供者发起的单一登录的应用程序输入登录 URL 时,可能会导致应用程序在没有 SAML 响应的情况下从应用程序反弹。
- 验证是否已正确配置登录 URL。
在Microsoft Entra 管理中心中使用测试 SSO 函数
Microsoft Entra 管理中心可帮助排查 SAML 配置错误。
- 在Microsoft Entra 管理中心中,转到“企业应用程序”,并单击需要故障排除的应用程序。
- 使用左侧导航菜单导航到 “单一登录 ”页
- 单击“ 测试此应用程序 ”以使用“测试 SSO”功能。
- 将收到的错误复制并粘贴到“解决错误”部分,然后单击“获取解决指南”
- 按照步骤排查错误
AADSTS750054
更多信息
有关 Active Directory 身份验证和授权错误代码的完整列表,请参阅Microsoft Entra身份验证和授权错误代码
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