尝试升级 MARS 代理时出错:Microsoft Azure 恢复服务代理更新失败
本文介绍尝试从旧版本升级到较新版本或较新版本的 Microsoft Azure 恢复服务 (MARS) 代理时出现的问题的症状和解决方法。
原始产品版本:Azure Site Recovery
原始 KB 编号: 4020490
症状
尝试使用 Microsoft Azure 恢复服务代理升级向导升级 MARS 代理时,升级失败,并收到以下错误消息:
Microsoft Azure 恢复服务代理更新失败。
错误:无法启动 RecoveryServicesManagementAgent 服务。 卸载修补程序
问题:更新安装失败,出现错误 1612
原因
出现此问题的原因是升级在 Windows Installer 缓存中找不到 MARS 代理的源安装程序。 需要源安装程序才能成功完成升级。
解决方案
若要解决此问题,请确保 Windows Installer 缓存中存在源安装程序。 为此,请按照下列步骤操作:
退出 Microsoft Azure 恢复服务代理升级向导。
打开文件夹中的OBPatch.log文件
C:\Windows\Temp
。找到要搜索“警告:本地缓存包”的 OBPatch.log 文件中的错误说明行。
找到如下所示的行:警告:
缺少本地缓存包 “C:\Windows\Installer\Unique_ID.msi。
请注意theUnique_IDvalue以供将来参考。
双击 MARS 代理更新安装程序 (.exe) 文件。 这会将所有与安装程序相关的二进制文件和安装程序文件复制到计算机上的临时位置,并打开 Microsoft Azure 恢复服务代理升级向导。
注意 使向导保持打开状态,直到步骤 12。
打开位于“C:\Windows\Temp”文件夹中的 OBInstaller0Curr.errlog 文件。
搜索“SetupLaunchScreen 的目录路径”文本,然后找到带有最新时间戳的行,如下所示:SetupLaunchScreen 的目录路径:
C:\Temp_ID
。转到
C:\Temp_ID\Installers
文件夹。在此文件夹中,找到 OBSAGENT.msi 文件并将其复制到 C:\Windows\Installer 文件夹。 将目标文件重命名为 Unique_ID.msi。
关闭 MARS 代理升级向导。
运行升级安装程序以安装升级。 如果问题仍然存在,请联系Microsoft 支持部门。
联系我们寻求帮助
如果你有任何疑问或需要帮助,请创建支持请求或联系 Azure 社区支持。 还可以向 Azure 反馈社区提交产品反馈。