Une erreur d’autorisation se produit même si l’accès Microsoft 365 a été activé

Cet article explique comment résoudre un problème lié aux autorisations que les utilisateurs peuvent rencontrer lors de la tentative d’accès aux enregistrements Business Central à partir de Microsoft Teams, même si l’accès avec des licences Microsoft 365 est correctement activé dans le Centre d’administration Business Central.

Symptômes

Lorsqu’un utilisateur sélectionne un lien ou un carte pour un enregistrement Business Central dans une conversation Microsoft Teams, il reçoit un message d’erreur semblable à « Désolé, les autorisations actuelles ont empêché l’action ».

Cause

Ce comportement est inhérent au produit. Les administrateurs doivent d’abord configurer les données accessibles dans Microsoft Teams. Si l’administrateur active l’accès dans le Centre d’administration Business Central, mais n’attribue pas d’autorisations sur la page Configuration de la licence , un utilisateur qui tente d’accéder aux enregistrements Business Central dans Microsoft Teams verra son enregistrement utilisateur approvisionné sans autorisation sur les objets.

Résolution

Remarque

Pour résoudre ce problème, vous avez besoin d’autorisations d’administrateur client dans Business Central.

Outre l’activation de l’accès Microsoft 365 dans Dynamics 365 Centre d’administration Business Central, attribuez également des autorisations sur la page Configuration de la licence. Toutefois, les autorisations attribuées sur la page Configuration de la licence s’appliquent uniquement aux utilisateurs nouvellement créés. Pour les utilisateurs qui ont déjà été créés, vous devez également attribuer les autorisations manquantes via la page liste Utilisateurs .

Informations supplémentaires

Create utilisateurs en fonction des licences